cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
J_Karlsson
Helper I
Helper I

iframe in powerapps portals is it only supposed to work for Bing???

When I try to add an iframe component and add a website it only works for Bing. Is it supposed to be like that?

I tried to add microsoft (see picture) but it didn't work it would be great to have some explanation on this issue.

I have tried to set the parameter http/X-frame options to ALLOW-FROM https:xxxx.powerappsportals.com instead of SameOrigin.

But that didn't work either.

iframe bing.pngiframe microsoft.png

 

 

2 ACCEPTED SOLUTIONS

Accepted Solutions

this is the documentation: https://developer.mozilla.org/en-US/docs/Web/HTTP/Headers/X-Frame-Options

I copied the iFrame from youtube and pasted on my Web Page HTML content

if you are using the Portal Studio to make your UI changes, just go to the </> HTML icon and place the iFrame wherever you want:

iframe.PNG

 


------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.




If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Power Apps Portals Super User


Oliver Rodrigues


 

View solution in original post

Hi,

Thanks for a quick reply and i Actually solved it a little bit before your answer and it was the issue with the little word embed.

<iframe width="420" height="315"
src="https://www.youtube.com/embed/tgbNymZ7vqY?autoplay=1">

</iframe> it seems strange though that @microsoft hasn't written anything about it in the documentation.
 

View solution in original post

6 REPLIES 6
OliverRodrigues
Super User
Super User

Which page exactly do you want in the iframe? 

 

the allow-from parameter is not be set in the Portals, but the target site of the iframe, is that what you did ?

 

https://developer.mozilla.org/en-US/docs/Web/HTTP/Headers/X-Frame-Options

 

------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.




If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Power Apps Portals Super User


Oliver Rodrigues


 

I would like add youtube for a clips from our company.

But first of all it would be interesting to know why only Bing is working.

 

you shouldn't have any issues with YouTube:

iframe.PNG

just did here as an example

please read the documentation from the I sent to better understand why it is not working with other sources

this is to prevent clickjacking attacks

I am not sure you setup the "allow-from" in your Power Apps Portals, you shouldn't be changing that unless you want to have your Portals as iFrame somewhere else

 

------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.




If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Power Apps Portals Super User


Oliver Rodrigues


 

Hi,

how did you get it to work?

I didn't get the documentation you said you sent me.

Kind Regards Johan

this is the documentation: https://developer.mozilla.org/en-US/docs/Web/HTTP/Headers/X-Frame-Options

I copied the iFrame from youtube and pasted on my Web Page HTML content

if you are using the Portal Studio to make your UI changes, just go to the </> HTML icon and place the iFrame wherever you want:

iframe.PNG

 


------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.




If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Power Apps Portals Super User


Oliver Rodrigues


 

View solution in original post

Hi,

Thanks for a quick reply and i Actually solved it a little bit before your answer and it was the issue with the little word embed.

<iframe width="420" height="315"
src="https://www.youtube.com/embed/tgbNymZ7vqY?autoplay=1">

</iframe> it seems strange though that @microsoft hasn't written anything about it in the documentation.
 

View solution in original post

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Users online (2,875)