cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
sanaaEl
Frequent Visitor

unable search zone in entity form

please i cant show items of relationship table in powerapps portal can you help me ?
14 REPLIES 14
sanaaEl
Frequent Visitor

sanaaEl_0-1617791422861.png

i cant show items of role beacause its disable;please how i can unable it?

Fubar
Solution Sage
Solution Sage

Does your Portal User have a Web Role that has Entity Permissions for the records in the Lookup (at a minimum would need read and append on the lookup entity's entity permission, and append to on the main entity's entity permission)

sanaaEl
Frequent Visitor

merci d'avance et comment je peux ajouter des autorisations

OliverRodrigues
Super User II
Super User II

Hi @sanaaEl please take a look at this article for more information on Entity Permissions: https://docs.microsoft.com/en-us/powerapps/maker/portals/configure/assign-entity-permissions

 




If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Power Apps Portals Super User


Oliver Rodrigues


 

sanaaEl
Frequent Visitor

Merci bcp encore une fois mais malheureusement j'arrive pas a trouver la solution 

OliverRodrigues
Super User II
Super User II

things to check:

  • Does your "Role" table contain data?
  • Create a new Entity Permission for the "Role" table, assign Read + Append + Append To privileges and associate the Authenticated (or Anonymous) Web Role



If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Power Apps Portals Super User


Oliver Rodrigues


 

Salut

j ai ajoutée des permission a l'entité rôle et j ai affecter les permissions au  rôle Web authentifié (ou anonyme) mais tjr le même problème 

OliverRodrigues
Super User II
Super User II

are you sure you have data in that table?

if you open the same form via Model-Driven App, does it bring any data? would you have changed the lookup view, for example adding some specific filters, and this could be causing the issue in the Portal maybe?




If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Power Apps Portals Super User


Oliver Rodrigues


 

Fubar
Solution Sage
Solution Sage

Did you tick Change Tracking on the Entity/Table definition - this is needed to push data to the Portals Cache.

Also, make sure you clear the portals cache (sync or yourportalurl/_services/about when signed in as a Portal user with the Administrators Web Role).

and that you signed out and signed back into the portal after updating the Web Role/Entity Permissions.

 

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Power Apps June 2021

June Power Apps Community Call

Did you miss the call? Check out the recording here!

Users online (19,953)