cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
PieterH
Frequent Visitor

Bug: Able to remove custom component while still in use on form

Today I remove a component from an unmanged solution. I forgot that the component was still used on a form.  After removing the component I realised this and found it strange that I was able to do so. Normally you get an error and can't remove something while still being refererence. I did go to the form and looked at the field. The new designer was still displaying information about the customer component I just removed. I removed the reference from the field and tried to save it. It gave me an ugly warning about not able to save the form... (old experience also didn't work) There wasn't anything I could do. I did import the solution containing the custom component and after this I was able to remove the reference from the form, save the form and finally remove the component.

I was lucky to have the original solution with the component laying around, otherwise I was left with a corrupt form. I think it is better to fix this before someone gets hurt 😉

@HansG 

5 REPLIES 5
sheldoncopper73
Resolver I
Resolver I

I as also face same using while using manage solution

namohant
Microsoft
Microsoft

Can we get more details especially a scenario and if possible the solution so that we can take a look further on this issue ?

 

- Nando

PieterH
Frequent Visitor

Hi, thanks for looking into this. I thought I already described it. Here it is again in more clear steps:

 

1) create component and upload the solution (in my case unmanaged)

2) use the component on a form, sae an publish

3) go to the solution with the component, find the component and remove it <= this should give a warning because it it still used

4) remove solution with the component

5) go to you form that did contain the control and try to modify and save <= this will give you an unclear error

 

At this stage you are unable to save any modifications to the form.

 

I tried several things to fix this, the only thing I could do to fix it:

6) import the original solution that did contain the component

7) go to you form that did contain the control and try to modify and save <= this will work now

 

I hope it is a bit more clearer

 

 

 

Thank you. We are checking this and will provide an update as soon as possible

 

-Nando

Hi @PieterH ,

 

We did check this on our end, following the scenarios we do see that all dependencies are being tracked appropriately. We are unable to re-create the scenario. Currently we are closing this as a non-issue. If you are still facing this issue. Kindly let us know and we can accordingly check if the issue still exists. 

 

- Nando

Helpful resources

Announcements
User Groups Public Preview

Join us for our User Group Public Preview!

Power Apps User Groups are coming! Make sure you’re among the first to know when user groups go live for public preview.

Power Apps Community Call

Monthly Power Apps Community Call

Did you miss the call?? Check out the Power Apps Community Call here!

Power Platform ISV STudio

Power Platform ISV Studio

ISV Studio is the go-to Power Platform destination for ISV’s to monitor & manage applications post-AppSource publish.

Users online (35,370)