cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Frequent Visitor

Canvas Apps on SharePoint Online Page not Loading when added URL to Teams

I am trying to add a SP page containing multiple PowerApps to a Teams tab using the URL app. The page loads fine however I need to "Sign-in" to each PowerApp on the page. When I select the sign-in button it launches the app in a seperate browser window. I have also tried adding the PowerApps to a Power Portal page and it provides the same issue? Is there anyway to get the PowerApps to load from the page embedded in the Teams tab?

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support
Community Support

Hi @vysta ,

Could you please share a bit more about your scenario?

Do you want to launch your embedded canvas app inside your Teams Tab rather than within a separated browser tab?
How do you embed your Power Apps app into your SP Page?

 

Regarding the issue that you mentioned, I have made a test on my side, and don't have the issue that you mentioned. The screenshot as below:

4.JPG

 

I embedded my canvas app into my SP Page using <iframe> HTML tag as below:

5.JPG

 

 

<iframe width="1024px" height="768px" src="https://web.powerapps.com/webplayer/iframeapp?source=iframe&amp;screenColor=rgba(104,101,171,1)&amp;appId=/providers/Microsoft.PowerApps/apps/xxxxxxxx-6519-xxxx-xxxx-66a0d31efcb8"></iframe>

 

Please consider use the <iframe> HTML tag to embed your canvas app into your SP Page, then embed your SP Page into your Teams Tab, check if the issue is solved.

 

Regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

1 REPLY 1
Community Support
Community Support

Hi @vysta ,

Could you please share a bit more about your scenario?

Do you want to launch your embedded canvas app inside your Teams Tab rather than within a separated browser tab?
How do you embed your Power Apps app into your SP Page?

 

Regarding the issue that you mentioned, I have made a test on my side, and don't have the issue that you mentioned. The screenshot as below:

4.JPG

 

I embedded my canvas app into my SP Page using <iframe> HTML tag as below:

5.JPG

 

 

<iframe width="1024px" height="768px" src="https://web.powerapps.com/webplayer/iframeapp?source=iframe&amp;screenColor=rgba(104,101,171,1)&amp;appId=/providers/Microsoft.PowerApps/apps/xxxxxxxx-6519-xxxx-xxxx-66a0d31efcb8"></iframe>

 

Please consider use the <iframe> HTML tag to embed your canvas app into your SP Page, then embed your SP Page into your Teams Tab, check if the issue is solved.

 

Regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Helpful resources

Announcements
New Badges

New Solution Badges!

Check out our new profile badges recognizing authored solutions!

New Power Super Users

Congratulations!

We are excited to announce the Power Apps Super Users!

Power Apps Community Call

Power Apps Community Call: February

Did you miss the call? Check out the Power Apps Community Call here.

Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

Users online (21,339)