cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
AppsUser1089
Frequent Visitor

Help) Power Apps with Power Automate

pic01.jpgpic02.jpgI created a power app to call the power automate.

 

Scenario)

1) Click  'Search' Button on Power Apps

Collect(RENVendor, GetVendorListByNameNoRange.Run())

2) Call Power Automate and Return responce

 

Power Automatic's run history is a success.

But, There is no data in the Collect named RENVendor.

 

responce JSON Schema

{
  "type""array",
  "items": {
    "type""object",
    "properties": {
      "ItemInternalId": {
        "type""string"
      },
      "dataAreaId": {
        "type""string"
      },
      "AccountNum": {
        "type""string"
      },
      "NameAlias": {
        "type""string"
      },
      "Name": {
        "type""string"
      },
      "LanguageId": {
        "type""string"
      },
      "@odata.etag": {
        "type""string"
      }
    },
    "required": [
      "@odata.etag",
      "ItemInternalId",
      "dataAreaId",
      "AccountNum",
      "NameAlias",
      "Name",
      "LanguageId"
    ]
  }
}
1 ACCEPTED SOLUTION

Accepted Solutions
rajyraman
MVP

@AppsUser1089- This usually happens if there is something wrong with schema vs what data is being returned. Did you make any changes to the Flow, after adding it to the canvas app? If so, try removing the Flow and re-adding it. You can also run Power Apps Monitor on you canvas app, and confirm that the response is coming through from Flow properly.

 

Just to confirm that the schema to data mapping is correct, try inserting a select before the response and map only specific properties, and returning the select on the response, with the correct schema, rather than dumping the raw response.

View solution in original post

6 REPLIES 6
rajyraman
MVP

@AppsUser1089- This usually happens if there is something wrong with schema vs what data is being returned. Did you make any changes to the Flow, after adding it to the canvas app? If so, try removing the Flow and re-adding it. You can also run Power Apps Monitor on you canvas app, and confirm that the response is coming through from Flow properly.

 

Just to confirm that the schema to data mapping is correct, try inserting a select before the response and map only specific properties, and returning the select on the response, with the correct schema, rather than dumping the raw response.

Thank you. 

 

After checking the power app monitoring, it receive the following responses.

I don't quite understand the following phrase. Can you give me more details?

"try inserting a select before the response and map only specific properties,"

 

pic5.jpg

 

{
"duration": 1628.58,
  "size": 58045,
  "status": 200,
  "headers": {
    "Cache-Control": "no-cache",
    "content-encoding": "gzip",
    "Content-Type": "application/json; charset=utf-8",
    "Date": "Tue, 31 Mar 2020 00:50:34 GMT",
    "expires": -1,
    "pragma": "no-cache",
    "strict-transport-security": "max-age=31536000; includeSubDomains",
    "timing-allow-origin": "*",
    "vary": "Accept-Encoding",
    "x-ms-apihub-cached-response": true,
    "x-ms-client-tracking-id": "08586159910519798959205356628CU24",
    "x-ms-correlation-id": "fb42ce4b-7439-4533-b02f-0f8e1e7a51dc",
    "x-ms-execution-location": "southeastasia",
    "x-ms-ratelimit-burst-remaining-workflow-writes": 14999,
    "x-ms-ratelimit-remaining-workflow-download-contentsize": 1073683779,
    "x-ms-ratelimit-time-remaining-directapirequests": 99999084,
    "x-ms-request-id": "southeastasia:fb42ce4b-7439-4533-b02f-0f8e1e7a51dc",
    "x-ms-tracking-id": "fb42ce4b-7439-4533-b02f-0f8e1e7a51dc",
    "x-ms-trigger-history-name": "08586159910519798959205356628CU24",
    "x-ms-workflow-id": "9c00c3d3039e473d8df9da3eaaa552b1",
    "x-ms-workflow-name": "d450e547-83c1-476e-855e-334c8af4fd75",
    "x-ms-workflow-run-id": "08586159910519798959205356628CU24",
    "x-ms-workflow-system-id": "/locations/southeastasia/scaleunits/prod-02/workflows/9c00c3d3039e473d8df9da3eaaa552b1",
    "x-ms-workflow-version": "08586160555562004112"
  },
  "body": [
    {
      "@odata.etag": "W/\"JzE2NTE1NjEyMiw1NjM3MTQ0NTc2Jw==\"",
      "ItemInternalId": "1db1d697-16db-48c1-a963-2297a22aa469",
      "dataAreaId": "yhc",
      "AccountNum": "V000001",
      "NameAlias": "연희화학(주)",
      "Name": "연희화학(주)",
      "LanguageId": "Ko-kr"
    },
    {
 
.
.
.
.
.
}
v-yutliu-msft
Community Support
Community Support

Hi @AppsUser1089 ,

Do you mean that you will get an empty result in powerapps from the response of flow?

I think the problem should be about your flow's configuration.

Could you show me more details about your flow's configuration?

Especially the response part.

Here are two similar issues for your reference:

https://powerusers.microsoft.com/t5/Building-Power-Apps/Returning-Array-via-Response-Blank-Array/td-...

https://powerusers.microsoft.com/t5/Building-Power-Apps/Issue-executing-a-SQL-SP-with-a-response-to-...

Here's a blog about "Return an Array from Flow to PowerApps" for your reference:

https://powerapps.microsoft.com/en-us/blog/return-an-array-from-flow-to-powerapps-response-method/

 

What's more, could you translate your language of your flow's configurations to English if you are convenient?

Sorry I' m not familiar with Korean.

 

 

Best regards,

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

Attached is the configuration and execution result of the flow I created.

 

 

 

pic001.jpgpic002.jpg

 

respoone schema

 

{
    "type""object",
    "properties": {
        "body": {
            "type""object",
            "properties": {
                "@@odata.etag": {
                    "type""string"
                },
                "ItemInternalId": {
                    "type""string"
                },
                "dataAreaId": {
                    "type""string"
                },
                "AccountNum": {
                    "type""string"
                },
                "NameAlias": {
                    "type""string"
                },
                "Name": {
                    "type""string"
                },
                "LanguageId": {
                    "type""string"
                }
            }
        }
    }
}
 
pic003.pngpic004.png

The operation was successfully completed even when we checked with power app monitoring.

 

pic006.jpg

I modified the power automate.

I have added a 'Select' before the 'Response' from the power automation.

I've checked the power apps to make sure the data is coming out right.

The data is properly visible in the power app.

 

my flow

Power Apps -> D365SCM connector -> Select -> 'Response'

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Power Platform Call June 2022 768x460.png

Power Platform Community Call

Join us for the next call on June 15, 2022 at 8am PDT.

PA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

This training provides practical hands-on experience in creating Power Apps solutions in a full-day of instructor-led App creation workshop.

PA.JPG

New Release Planning Portal (Preview)

Check out our new release planning portal, an interactive way to plan and prepare for upcoming features in Power Platform.

Top Kudoed Authors
Users online (2,901)