cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Nijo
Helper I
Helper I

Images refereed in react framework's CSS is not loading in PCF

Hi,

I'm using a react component with PCF, the component uses primefaces library, and CSS, and it refers to some SVG images and some other assets. I tried manually referring the said assets in PCF manifest but it's not loading the images in the control, has anyone tried this before? am I missing some other configurations?

Many thanks 

 

2 ACCEPTED SOLUTIONS

Accepted Solutions
RAWilson
Resolver I
Resolver I

Could you please post how you referenced the resource files in your manifest file?  Also could you post a few of the places in the code where it references the resources.  My first guess is that it's a path issue.

 

Rick

View solution in original post

Please post how they are referred in CSS. As @RAWilson suggested it may be the path issue. As both images and CSS are in same folder structure when referring them in css you will need font/external.svg

Power Maverick | Microsoft Business Application MVP

View solution in original post

5 REPLIES 5
RAWilson
Resolver I
Resolver I

Could you please post how you referenced the resource files in your manifest file?  Also could you post a few of the places in the code where it references the resources.  My first guess is that it's a path issue.

 

Rick

View solution in original post

Hi

I am using a CSS, that CSS refers to some icon assets through inline. I have 10's of assets that were referenced by the CSS library I use in my app, I could track the folder structure and put the assets in the relative path like the library originally did
I referenced the manifest file like below

<css path="CSS/primereact.min.css" order="2" />
<css path="CSS/theme.css" order="2" />
<css path="CSS/primeicons.css" order="2" />
<img path="CSS/fonts/external-link.svg"  />
<img path="CSS/fonts/chevron-down.svg"  />


As you can see, I organised the assets folder relative to the way the CSS originally managed them, my PCF control is loading the CSS but not it's not picking the images.
Many Thanks

Nijo

 

 

Please post how they are referred in CSS. As @RAWilson suggested it may be the path issue. As both images and CSS are in same folder structure when referring them in css you will need font/external.svg

Power Maverick | Microsoft Business Application MVP

View solution in original post

Hi,

@RAWilson @PowerMaverick   Yes I got the issue in the CSS it was referred as  

 src:url('./fonts/primeicons.svg?#primeicons') format('svg');

It is working when I changed to

 src: url('fonts/primeicons.svg?#primeicons') format('svg');

 

Thank you.

Nijo

eleung83
Regular Visitor

I'm not sure what the url() command returns, although I guess in your example it returns the correct url to the exact svg file. 

 

From this older post here, it does seem like the official correct way to access these resources is by using the api getResource method discussed here. It may be there's a better way since then, but i've used a similar method for rendering png image resources.


Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Users online (57,305)