cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
hakisan
Advocate I
Advocate I

OnChange property disappeared from components

Hi, I'm having some problems with the component made with PCF. As you can see below, the OnChange property is completely gone.

hakisan_0-1604557399462.png

hakisan_1-1604557490857.png

I'm using @RAWilson big calendar for canvas app atm, but the problem is present with all of my other components. OnChange can't be found anywhere. This only happen a few hour ago, the property was still there this morning, It seems likely to be a problem with new powerapps update.

Hope this can be resolved soon, thank you.

 

2 ACCEPTED SOLUTIONS

Accepted Solutions

Do remember that PCF in Canvas Apps is still in preview and not intended for use in production yet!

View solution in original post

HemantG
Power Apps
Power Apps

This is a regression issue and is not intentional removal . We have identified the fix and working on the deployment for the same. 

 

Apologies for the inconvenience caused. Please reach out to me if there are any questions .

 

hemant 

View solution in original post

17 REPLIES 17
LeHoangVu
Advocate I
Advocate I

Same problem, need help !

hakisan
Advocate I
Advocate I

pump

AyeChan
Frequent Visitor

same problem too.

AyeChan
Frequent Visitor

Hi Hakisan! I have face with same problem too. When did you notice this problem? me, Saturday. Thank you.

 

nicompte
New Member

I'm having the same issue, when I import the PCF into my application, the OnChange field is present, but:
- it's actually only working in edit mode (using Alt + click, and Play), not when I publish the app

- when I close and re-open the app, the field is gone

 

I'm not sure when it stopped working though.

I noticed it after powerapps version 3.20103.28, so around Thursday last week.

JasperC
Regular Visitor

Bump.

We are experiencing the same issue in Version 3.20104.33.

 

Initial use of the PCF control in the app works perfectly. When the app is opened for a second time the OnChange action seems to broken whenever it is filled in. We always get the following error:

JasperC_0-1605010072390.png

The formula is: Set(_varTest, ShapeDrawingBoard1.Output)

This clearly does not contain any operator and therefore the error seems invalid.

DanielZZ
Frequent Visitor

Same Issue, the onChange is missing
I have the same component in 2 different tenants and in one is missing and in the other is still present. No changes made lately. 
Both have the same version 3.20104.33

@HemantG - any update on this - it's causing some pain!

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Users online (43,618)