cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Packaging a code component with spaces in the folder path throws error

Packaging a code component with spaces in the folder path throws error. FolderWithSpaceIssue.png


Power Maverick | Microsoft Business Application MVP
2 ACCEPTED SOLUTIONS

Accepted Solutions

Hi there, this issue should be addressed in the next update.  Thank you.

View solution in original post

Hi @PowerMaverick ,

I took a look at the error and I tried to reproduce issue using the exact same version. However I was not able to repro and we are also aware that this issue was fixed a while back. Can you potentially try to re-install the tool? If it still doesn't work I suggest to rename the folder to work around this issue until the root cause is identified by us. Thank you and sorry for the inconvenience.

View solution in original post

11 REPLIES 11
alchin
Microsoft
Microsoft

Hi,

 

Can you try wrapping the --path argument value in double quotes like:

 

pac solution add-reference --path "C:\Users\dnaglekar\Documents\test\Folder With Space"

 

The Help output further explains that values with spaces require quotes.

 

Thanks,

Alex

Already tired it but still fails. See the posted image in orginal question above (highlighted in yellow)


Power Maverick | Microsoft Business Application MVP

Ah apologies, I didn't notice that you already tried with double quotes.  Let me try reproducing and filing a defect on this.

 

Thanks,

a/c

Hi there, this issue should be addressed in the next update.  Thank you.

Awesome. Thanks

Power Maverick | Microsoft Business Application MVP

May I know when is the next update scheduled to address this issue?

Power Maverick | Microsoft Business Application MVP

Can you pls. provide additional details on this? Thanks

Hello @PowerMaverick ,

 

The major version of the CLI has been bumped to 1.x four weeks ago. This issue should be resolved in the latest update. Please follow this post  for details upgrade steps. Thank you!

Hi @sgpchenchang

That's what I thought. My PCF CLI is updated to the latest version. As you can see in the screenshot attached the PCF CLI version is 1.0.6 but when adding reference of a component to solution throws an error. I have wrapped the path in quotes as well. This is only happening for add-reference command.


Power Maverick | Microsoft Business Application MVP

Helpful resources

Announcements
Power Apps Africa Challenge 2022

Power Apps Africa Challenge

Your chance to join an engaging competition of Power Platform enthusiasts.

Super User 2 - 2022 Congratulations

Welcome Super Users

The Super User program for 2022 - Season 2 has kicked off!

September Events 2022

Check out all of these events

Attend in person or online, there are incredible conferences and events happening all throughout the month of September.

Government Carousel

New forum: GCC, GCCH, DoD - Federal App Makers (FAM)

In response to the unique and evolving requirements of the United States public sector, Microsoft has created Power Apps US Government.

Users online (1,886)