cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Potential issue when two controls with similar features

Hi,

Just bit of a feedback which looks like a bug. Basically I imported a dataset custom control, bound it to the view in CRM and rendered it. Then I went into the source code and changed the namespace of this control and some other features like Description, etc. Imported the solution again.

 

Now I can see both custom controls inside CRM solution. However, the view to which the first control is bound seems confused. It does not show any control at all in the Customize View > Custom Controls area (not even the default Read Only view which is always there).

 

The solution was to delete the second control, unbind the first one from the view, delete first one, import the second control again and then finally bind the second to the view.

 

Cheers

5 REPLIES 5
Highlighted
Frequent Visitor

I am noticing that when a faulty custom control somehow makes into CRM, it can cause the Add Control list of any view to become blank.

 

Steps to replicate

1. Goto any view and open properties

2. Choose Custom Controls > Add Control

3. You can see a list of of the default controls like Calendar, CardFeed, MailAppList, etc.

 

But when I have a faulty control (as explained in the previous step), this list does not appear at all and you rather see a message saying 

There are no controls compatible with type (Grid) available.

 

I think there should be some kind of isolation in place to restrict the rogue control from bringing down the entire list. 

 

Highlighted

Thanks Manny, that indeed is a bug. Would mind sharing the solution which can repro this, I was not able to repro.

 

Note that if the namespace and name of the control is changed, it becomes a brand new control at that time.

Highlighted

Attached is the solution file containing the faulty control.

Highlighted
New Member

Any updates on this?

Still happening as of today.

Highlighted

hi,

 

I am not sure about the exact steps. I did check the solution from Manny. Does not look like there are problems.

From the thread, it seems need to 2 solutions, first import some solution, then import another one then we see blank list

 

Now, to solve the issue, we could do either one of below:

1) Some one shares the right steps with 2 solutions to us, then we check and identify the bug

or if u r blocked

2) Some one just open a ticket and specify the repro steps. Our support engineer will reach to you, there might need a copy but we don't need data. 

 

For option 2), we will provide DB mitigation if needed.

If you want privately sync, feel free to send email to us, my email is achen@microsoft.com

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Users online (7,882)