cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ACRMUser
New Member

Power Platform build tool Create Environment

Hello,

i am trying to create an environment in a Pipeline using the Power Platform build tool.
When I connect to the Service Principal and select Europe as my region I get an error message:
##[error]The region 'europe' is invalid. Please enter the valid region or select from the picklist

When I use the username/password I get the following error:
##[error]environment is not created. error: @{Code=400; Description=Bad Request; Headers=Pragma: no-cache

Unfortunately I don't know what to do now. Enclosed you find my logfiles.

3 REPLIES 3
v-jefferni
Community Support
Community Support

Hi @ACRMUser ,

 

As per your description that you were creating an environment through Power Platform Build Tools, please first check the capacity to see if it allows to create new environments:

https://docs.microsoft.com/en-us/power-platform/alm/devops-build-tool-tasks#environment-management-t...

 

Note:

A new environment can only be provisioned if your license or capacity allows for the creation of additional environments. For more information on how to view capacity see Capacity page details .

 

If that is not the reason of the issue you encountered, it would be hard to find the problem in the community, you could rise a ticket on the support page with the log files:

https://powerapps.microsoft.com/en-us/support/

 

Hope this helps.

 

Best regards,

Community Support Team _ Jeffer Ni
If this post helps, then please consider Accept it as the solution to help the other members find it.

 

 

FH-Inway
Frequent Visitor

Hello,

did someone find a solution to this issue? I'm facing it, too. Capacity for me is not the issue (and I would hope that the error message would be different if it was). The link to the support page offers a link to report an issue, but that leads me just right back to this forum.

Awallep
Frequent Visitor

I had this issue and contacted support for it. they sent me this link Programmability and Extensibility - PowerShell - Creating a service principal - Power Platform | Mic.... It worked for me, so could be worth a try. 

make sure you have the module installed. you should have it, but just incase. 

Install-Module -Name Microsoft.PowerApps.Administration.PowerShell

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Power Apps Community Call Jan. 2022 768x460.png

Power Apps Community Call

Please join us on Wednesday, January 19th, at 8a PDT. Come and learn from our amazing speakers!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Users online (2,791)