cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
vermaaman
Helper II
Helper II

PowerApp button trigger flow connection broken in Solution Packager

Hello,

 

I have created an app and packaged in under a solution packager.

 

The app is connect with power automate using PowerApps trigger button. After making all the changes the app was published.

 

Give the app to other users to use the app but when they click on the button which triggers power automate it throws this error. 

 

vermaaman_0-1620709378788.png

 

Error: "TeamRequestAutomation.Run failed: Connection not configured for this service."

Can someone please advise what is wrong when binding all the flow and app in Solution Packager?

Thank you!

 

1 ACCEPTED SOLUTION

Accepted Solutions

Hi @v-xiaochen-msft  - I was able to get this working with the help of Post and comment in it by @aaroh_bits .

Thank you @v-xiaochen-msft  for staying with me so far 🙂 

I performed these steps in my test environment and it worked for all the users without any addition permission on workflow. 

 

  1. Navigate to Power Apps Admin Center
  2. Selected the Environment you are working. 
  3. Click on Settings on top bar.  
  4. Go to User + Permissions >> Security Roles  
  5. Under the Security Roles, find the Basic User role , click on  ellipses (...) >> Edit
  6. Under Customization tab >>  Select Process >> assign Read access to the Organization

 


I will also follow the steps you have mentioned in the previous comment and let you know here how it went, thanks for that.

View solution in original post

11 REPLIES 11
v-xiaochen-msft
Community Support
Community Support

Hi @vermaaman ,

 

If your app is in solution, you need to create flow in solution instead of creating flow externally.

v-xiaochen-msft_0-1620716452131.png

 

Best Regards,
Wearsky
If my post helps, then please consider Accept it as the solution to help others. Thanks.

 

Hi @v-xiaochen-msft  - I did exactly the same as i read the limitations here - https://docs.microsoft.com/en-us/powerapps/maker/data-platform/solutions-overview#known-limitations but still not able to connect.

 

 

v-xiaochen-msft
Community Support
Community Support

Hi @vermaaman ,

 

Please try to share flow to other users.

v-xiaochen-msft_0-1620717548856.png

v-xiaochen-msft_1-1620717567332.png

v-xiaochen-msft_2-1620717589716.png

 

After sharing, please try to delete and re-add the flow in the canvas app, save and publish.

 

Best Regards,
Wearsky
If my post helps, then please consider Accept it as the solution to help others. Thanks.

 

 

 

Hi @v-xiaochen-msft  -  I think it worked when i shared with one user but how am i suppose to share with everyone in the organization as we don't know who is the approver going to be ?

Any advice?

v-xiaochen-msft
Community Support
Community Support

Hi @vermaaman ,

 

I just share the app, other users can also use the flow in the app.

If you only share the app and other users cannot use the flow of the app, this may be caused by some users' permissions/roles or other issues.

I have difficulty reproducing the problem.

 

A more stable method is to use the scheme I mentioned above.You could share flow to users you want to share.

 

Best Regards,
Wearsky
If my post helps, then please consider Accept it as the solution to help others. Thanks.

vermaaman
Helper II
Helper II

HI @v-xiaochen-msft  - This is what I have done.

1 - Imported the app in the tenant
2 - Added the imported app in Solution
3 - Then created the PowerApps button trigger flows from within the App which created the flow inside the solution.
4 - Shared the App with everyone in the organization 

Not sure what is scheme method which you are suggesting, any link for reference?

Also reproduced the same issue in another tenant where i created PowerApp inside a solution then added powerApp trigger button then saved the app and flow then shared the app with everyone in the organization and when i accessed the app using a different user within same tenant it throws the same error.
 
But then when i shared the PowerApp trigger flow with the user individually it worked 😞 

v-xiaochen-msft
Community Support
Community Support

Hi @vermaaman ,

 

My solution is what you are using now. (Share the flow and app with users instead of sharing the app )

Although the steps may be cumbersome, it is feasible.

 

 

Best Regards,
Wearsky
If my post helps, then please consider Accept it as the solution to help others. Thanks.

Hi @v-xiaochen-msft  - You are right, for testing purpose I did share the flow with users but that's not the default behavior ( my understanding : sharing the app will also share the flow ) and it's not something that we are excepting because we need to share this app with everyone in the organization and sharing flow with everyone within the organization isn't allowed i guess.

Again i am stuck at the same question 😞 

v-xiaochen-msft
Community Support
Community Support

Hi @vermaaman ,

 

Please try this:

1\ Import your solution from environment A to environment B

2\ In environment B, click the solution- edit the app-delete the flow - add the flow again - save the app - publish the app

3\ share the app with everyone 

 

Best Regards,
Wearsky
If my post helps, then please consider Accept it as the solution to help others. Thanks.

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Power Apps June 2021

June Power Apps Community Call

Don't miss the call this month on June 16th - 8a PDT

Users online (51,502)