cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
BetimBeja
Advocate II
Advocate II

SolutionPackager.exe Incorrect handling of StandardError

Hello,

I am building a tool for XrmToolBox and calling SolutionPackager.exe with Process class. The problem I am facing is that when there is an exception in the tool the message does not get written to the StandardError, but to the StandardOutput stream. Even if I specify /errorlevel:Off the tool still writes the exception details in the StandardOutput stream.

 

It is a minor issue but if this can be fixed it would be great 🙂

 

Best regards,

Betim.

1 ACCEPTED SOLUTION

Accepted Solutions
alrez
Community Support
Community Support

Hi,

 

Looking through your issue, this seems like it might reach a certain technical level that this might be better as a Microsoft Support Request. Communities might still be able to help you out but I would suggest opening a ticket with Microsoft Customer Support. I'll include a link below; on creating a ticket.

 

If you would like to create a ticket with Microsoft Customer Support here is a link on how to do so: https://docs.microsoft.com/en-us/power-platform/admin/get-help-support

 

Regards,

 

Alex

 

-------

 

Community Support Team _ Alex Rezac
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

2 REPLIES 2
alrez
Community Support
Community Support

Hi,

 

Looking through your issue, this seems like it might reach a certain technical level that this might be better as a Microsoft Support Request. Communities might still be able to help you out but I would suggest opening a ticket with Microsoft Customer Support. I'll include a link below; on creating a ticket.

 

If you would like to create a ticket with Microsoft Customer Support here is a link on how to do so: https://docs.microsoft.com/en-us/power-platform/admin/get-help-support

 

Regards,

 

Alex

 

-------

 

Community Support Team _ Alex Rezac
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

I don't have the possibility to open a support request as I don't have a subscription, I am just building an open-source tool and there is a bug with a Microsoft tool that I am trying to use. I wrote here because maybe someone already faced this and there might be some workaround to it. An important part of my post is that it is a minor issue.

 

Best regards,

Betim Beja.

Helpful resources

Announcements
PA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

secondImage

Power Apps Community Call

Please join us on Wednesday, October 20th, at 8a PDT. Come and learn from our amazing speakers!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Users online (1,550)