Today I'm programming on an other computer. I don't know what's the different to my old computer.
If I run
npm run start watch
Error [ERR_PACKAGE_PATH_NOT_EXPORTED]: Package subpath './v4' is not defined by "exports" in ...\node_modules\uuid\package.json.
In the files
var uuidv4 = require('uuid/v4');
Hi @FlorianGrimm ,
In the uuid npm package, it seems that deep requires are deprecated with version 7 (https://www.npmjs.com/package/uuid#deep-requires-no-longer-supported)
But the PCF seems to use uuid version "^3.3.2" (if I see this right in the "node_modules/pcf-scripts/package.json") , which means that it might install until uuid v3.4.0. In th v3.* where the deep requires were supported: https://www.npmjs.com/package/uuid/v/3.3.2
It seems to me that it's using the latest version of uuid, but I'm not sure why. If you say, it's only on another computer, I would think on global install of uuid with a newer version, but I have no idea why the local install is not taken.
Maybe you can use "npm list" and check which version of uuid is used.
Hope it helps!
it seems jest does this to me...
+-- email@example.com | +-- @firstname.lastname@example.org | | +-- @email@example.com | | +-- @firstname.lastname@example.org | | | +-- email@example.com | | | | +-- firstname.lastname@example.org | | +-- email@example.com | | | +-- firstname.lastname@example.org | | | | +-- email@example.com deduped | | | | `-- firstname.lastname@example.org | | | | +-- email@example.com | | | | | `-- firstname.lastname@example.org | +-- email@example.com | | +-- firstname.lastname@example.org | | `-- email@example.com | | `-- firstname.lastname@example.org | +-- email@example.com +-- firstname.lastname@example.org | +-- email@example.com | | +-- firstname.lastname@example.org | | | `-- email@example.com
so I used
npm install uuid@^3.3.2 --save-dev
the mysteries of node_modules .. I will (want) never understand
txs for the hint
I am getting the same error while running the command 'npm start'
Package subpath './v4' is not defined by "exports" in ..\node_modules\pcf-start\node_modules\uuid\package.json
Node.js version - node-v14.17.1-x64
Any suggestion please to resolve this issue?
Hi @mpnandini ,
These days there seems to be another issue with the pac cli 1.7.2. which brings the error.
There is another thread on this one, maybe it helps: https://powerusers.microsoft.com/t5/Power-Apps-Pro-Dev-ISV/PCF-npm-run-build-Error-self-signed-certi...
@floriangrimm yes, a regression has snuck in with our latest release 1.7.2, we're sorry for the inconvenience 😞
As you mentioned, pinning to an older version in your package.json will for now let you work around.
We're working on releasing a hot fix to update the localfilesetting.ts file to properly require the v4 submodule
Join us for the next call on August 17, 2022 at 8am PDT.
The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.