cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
JohnZheng
Helper I
Helper I

"No data available" error for general web resource from SiteMap

I have experienced "No data available" error when I use mobile browser on app what has web resource from SiteMap in PowerApps. I thought it might be some issues of our responsive design in our components, which are complicated React UI components. I was not able to find anything wrong. A Google search lead me to this url: https://github.com/MicrosoftDocs/powerapps-docs/issues/867 

 

However, today I was able to reproduce the issue with a simple "hello world" html web resource. I added a simple HTML as a web resource in my App, add a link to it on the site map of the app. Then I was able to reproduce this "No data available" issue by resizing the browser width. I can also see this in the mobile browser. Both video gif are attached. 

 

I am super surprised of this common error when dealing with a customized webresource html from PowerApps site map. I am going to submit a supporting ticket to Microsoft. But anyone know any workaround for this issue? TMT HelloWorld Html Resize.gifTMT HelloWorld Html Mobile.gif

1 ACCEPTED SOLUTION

Accepted Solutions
JohnZheng
Helper I
Helper I

Sorry I did not put a closure on this. It is one of the switches in solution that have an impact. I was able to finally resolve it a while back. I believe you need to open the html web resource file in solution. Then make sure to check "Enable for mobile"

JohnZheng_0-1642464862485.png

 

View solution in original post

7 REPLIES 7
JohnZheng
Helper I
Helper I

I have a support ticket opened with Microsoft and they were able to reproduce the issues. They are working on it...

Muthuraman382
New Member

Hi Could you please let us know is this issue resolved. we are getting the same issue e when loading HTML web resource in offline mode

 

a33ik
MVP

It seems that the issue is still relevant - I was doing some prototyping with Html Webresource that should work offline and it doesn't work the way it should embedded into the SiteMap.

JohnZheng
Helper I
Helper I

Sorry I did not put a closure on this. It is one of the switches in solution that have an impact. I was able to finally resolve it a while back. I believe you need to open the html web resource file in solution. Then make sure to check "Enable for mobile"

JohnZheng_0-1642464862485.png

 

a33ik
MVP

Enable for mobile and Available Offline checkboxes are checked and it doesn't work.

I digged out the email thread with Microsoft supporting engineer on this issue. The "Enable for Mobile" on the webresource html was the fix for me. Based on my response at the time, you may need to wait a little while. 

 

JohnZheng_0-1642747040816.png

 

More screenshot from MS

 

JohnZheng_1-1642747209633.pngJohnZheng_2-1642747258187.png

 

Helpful resources

Announcements
PA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

This training provides practical hands-on experience in creating Power Apps solutions in a full-day of instructor-led App creation workshop.

Microsoft Build 768x460.png

Microsoft Build is May 24-26. Have you registered yet?

Come together to explore latest innovations in code and application development—and gain insights from experts from around the world.

May UG Leader Call Carousel 768x460.png

What difference can a User Group make for you?

At the monthly call, connect with other leaders and find out how community makes your experience even better.

Top Solution Authors
Users online (1,279)