cancel
Showing results for 
Search instead for 
Did you mean: 

Using Expand Query in Power Automate with CDS

Power Automate plus the Common Data ServicePower Automate plus the Common Data Service

 

Before We Dive In

If you use Power Automate (Flow) and model-driven Power Apps, then (hopefully) you are aware of the “Common Data Service (current environment)” (CDS-ce) connector. Within this connector, there is an “Expand Query” option. This blog post will help explain how to use this.

 

Note: Check out Sara Lagerquist’s excellent blog called “CDS vs CDS: What Connector should I use in Power Automate?“. This will help you understand the difference between the Common Data Service connectors.

Let’s Dive In Power Apps Solution

To get started, I have already created a solution within the Power Apps maker site called “PA Flows” (for “Power Automate Flows”). The next step would be to create a new flow within the solution.

 

Power Automate solution created within Power Apps maker sitePower Automate solution created within Power Apps maker site

 

Create new Power Automate flow within solutionCreate new Power Automate flow within solution

 

 

Note: For this example, I have already started a flow with a Flow Button as the trigger. You can utilize whatever trigger you would like within your flow(s).

The Flow Setup

In the flow, I have a “List Records” action (renamed “List Opportunities”). In this example I am listing the Opportunities from Dynamics 365. I also have a simple ODATA “Filter Query” of “statecode eq 0” (0 = Active/Open).

 

Read more...

Comments

@PowerBack19  Thanks for the instructions. Though I still cannot get the 'fields' I called from other entities. So following your instructions, I did the following:expand query.JPG

expand query 2.JPG

As you can see, I am not getting the 'first name' field. Then I thought there might be an issue with the schema. So, ran the flow to see how the result of previous step (list records) look like. And I have the following result:

expand query 3.JPG

 

Having followed the instructions, I m not entirely sure where this has gone wrong. Can you help with this?

 

Many thanks,

 

@Ksepahman - I would suggest you set the HTML columns to "Automatic" and do a test run. Then check the output to see what is listed.

Meet Our Blog Authors
  • Experienced Consultant with a demonstrated history of working in the information technology and services industry. Skilled in Office 365, Azure, SharePoint Online, PowerShell, Nintex, K2, SharePoint Designer workflow automation, PowerApps, Microsoft Flow, PowerShell, Active Directory, Operating Systems, Networking, and JavaScript. Strong consulting professional with a Bachelor of Engineering (B.E.) focused in Information Technology from Mumbai University.
  • Encodian Owner / Founder - Ex Microsoft Consulting Services - Architect / Developer - 20 years in SharePoint - PowerPlatform Fan
  • Cambridge UK Power Platform User Group Leader, Technical evangelist and speaker. Always says yes to coffee! #LetsGetCoffee
  • Passionate #Programmer #SharePoint #SPFx #Office365 #MSFlow | C-sharpCorner MVP | SharePoint StackOverflow, Github, PnP contributor
  • I am building business processes and applications that are easy for users' to stick to, so they can follow and understand them. In overall I transform processes to be more reliable and effortless. I am a proud co-organizer of SharePoint Saturday Warsaw and active community member, blogger and international speaker.