cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
chipde
New Member

Can I log in to Power Automate Desktop via proxy?

We use a company proxy. Unfortunately, Power Automate Desktop seems to completely ignore the proxy stored in Windows. Is there a way to get PAD to use the proxy when logging in?

8 REPLIES 8
Philipp-SG
Regular Visitor

@chipde , how did you solve the problem ? did you find any workaround ?

fraenK
Memorable Member
Memorable Member

There might be something wrong with your Windows proxy settings or your proxy configuration blocking requests. It works fine for me with a proxy.

https://docs.microsoft.com/en-us/power-automate/desktop-flows/setup#prerequisites

https://docs.microsoft.com/en-us/power-automate/ip-address-configuration

 

No, I haven't found a workaround. I solved the problem by not using this product. 😉

I do not believe that. The proxy does not even receive requests.

fraenK
Memorable Member
Memorable Member

The your proxy configuration in Windows is the source of the problem.

Philipp-SG
Regular Visitor

update

still not working , tried today in office without VPN and its still not working.  I checked network traffic and I see the request from PAD to login and the response from proxy to authenticate. Offering three options. After this there is no more request from PAD and the error message appear . Looks for me the PAD client has a bug in the proxy authentication and get stuck.

 

 

2021-04-14_10h27_35.png

 

 

Solved 
Fiddler showed that dns cloud not be resolved for login.microsoftonline.com...
Looks like my cisco vpn client in version 4.7 didnt resolve the hostname proper after updating to cisco vpn version 4.9 dns resolution is working fine and I can also connect with my proxy (with Kerberos auth) 

SandiC
New Member

Hi,


I see that you get error 407 proxy "authentication". This is already the proxy reply, so you are calling it but without authenticated credentials. We had the same issue and we fixed it with setting the proxy settings to the Power Automate config files:

C:\Program Files (x86)\Power Automate Desktop\PAD.Console.Host.exe.config

C:\Program Files (x86)\Power Automate Desktop\PAD.Designer.Host.exe.config


This code has to be added to the PAD.Console.Host.exe.config and PAD.Designer.Host.exe.config:

<system.net>

<defaultProxy useDefaultCredentials="true" enabled="true">

<proxy usesystemdefault="True" proxyaddress="http://YourProxyDNS:PORT" bypassonlocal="True" />

</defaultProxy>

</system.net>

 

Wehre to put? Find this part of code:
(before)
...
<setting name="DataCollectionActiveFileDeletionInterval" serializeAs="String">
<value>00:05:00</value>
</setting>
</PAD.Console.Host.Properties.Settings>
</userSettings>
</configuration>

 

insert the <system.net> after the </userSettings>:
(after)
...
<setting name="DataCollectionActiveFileDeletionInterval" serializeAs="String">
<value>00:05:00</value>
</setting>
</PAD.Console.Host.Properties.Settings>
</userSettings>
<system.net>
<defaultProxy useDefaultCredentials="true" enabled="true">
<proxy usesystemdefault="True" proxyaddress="http://proxy:8080" bypassonlocal="True" />
</defaultProxy>
</system.net>
</configuration>

Philipp-SG
Regular Visitor

@SandiC  , thanks a lot . Creating the config file and  enable use of default credentials fixed the problem .

Helpful resources

Announcements
MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Users online (17,623)