cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
TesDA
Continued Contributor
Continued Contributor

Cannot create new session to execute unattended run

I've looked through all of the current posts on this and they didnt help. 

 

We are using a service account on an Azure Virtual Desktop using a machine (not a gateway). 

The Service Account does have a Power Automate license and and we have an unattended license for the environment it is using. 

The machine is showing as connected, so I know the virtual desktop is online and running power automate when no one is logged on. 

 

What could be going on? 

1 ACCEPTED SOLUTION

Accepted Solutions
TesDA
Continued Contributor
Continued Contributor

After alot of back and forth with our colleagues in our national dept we learned that we need a gateway

View solution in original post

7 REPLIES 7
mattias1172
Responsive Resident
Responsive Resident

What is the exact error you are getting?

 

Also, to be sure, no one is logged in at the same time the flow tries to connect? If your running windows 10/11, only 1 logged in user at a time is supported. 

TesDA
Continued Contributor
Continued Contributor

@mattias1172  We're running Windows Server 2016 Datacenter. Does it need to be a later version of Windows Server?

TesDA
Continued Contributor
Continued Contributor

I just checked the docs and it looks like Power Automate Desktop supports Windows Server 2016 Datacenter however that might be outdated. https://docs.microsoft.com/en-us/power-automate/desktop-flows/setup

mattias1172
Responsive Resident
Responsive Resident

If the VM matches the prerequisites, try setting up power automate runtime on another computer and running the unattended flow on that. This will being to shorten our potential problems. 

 

elaaboum
Microsoft
Microsoft

Hi @TesDA ,

 

could you share the runId of the unattended run that failed with that error. (see screenshot below for how to get that runId):

 

elaaboum_0-1648799827588.png

 

TesDA
Continued Contributor
Continued Contributor

After alot of back and forth with our colleagues in our national dept we learned that we need a gateway

Hello,

Experiencing the same issues here, wouldn't know how to solve as I bump on this error quite inconsistently.

Here's a runID of my unattended run:

AlexScharp_0-1663051427768.png

 

Any idea how this issue could be resolved?

 

Kind regards,

Alex

 

Helpful resources

Announcements
Power Automate News & Announcements

Power Automate News & Announcements

Keep up to date with current events and community announcements in the Power Automate community.

Community Calls Conversations

Community Calls Conversations

A great place where you can stay up to date with community calls and interact with the speakers.

Power Automate Community Blog

Power Automate Community Blog

Check out the latest Community Blog from the community!

Top Solution Authors
Top Kudoed Authors
Users online (2,763)