cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Andrewlu81
Helper II
Helper II

I have define a label on flow, but is show no label availabel?

In my flow, sometime there is no data, extract data from web, might appear error.

I want if error happen, and skip to special label station, it can be continue.

I have define a label, but is show no label?

why?No Label.JPG

1 ACCEPTED SOLUTION

Accepted Solutions
Adrian_AUT
Frequent Visitor

I already tried it, exactly thats the plan. If there is an error, GO TO LABEL. But sadly there is the problem it, can´t find the labels. I tried to Jumt to a label (cant be found) or to a subflow both options doesn´t work.

It seems label only works IN one loop, but not in the whole subflow/flow.

EDIT: Just to clarify because it was markted as solution. It is still a BUG! in my opinion. It has to be a solution that i can use a Label over the whole projekt, or at least in the same flow!

View solution in original post

9 REPLIES 9
kostasc
Microsoft
Microsoft

Hey @Andrewlu81 

This is a known issue, and we have it in our backlog to be addressed. We will try to provide a fix in the Feb release.

MichaelAnnis
Super User
Super User

In the meantime, as a workaround:

    If web page doesn't contain element"

        Go to label

    End (If)

 

This method should work.

Guriga
Advocate II
Advocate II

I have a similar problem.

https://powerusers.microsoft.com/t5/I-Found-A-Bug/No-label-available-PAD/m-p/1433436#M10140

I did almost the same workaround as @MichaelAnnis wrote until the update fix the issue.

Adrian_AUT
Frequent Visitor

So it seems the Labels are still not working correctly on the last Version Sept 2022 2.23.114.22217.

Sometimes it shows the label and sometimes not. I don´t get it that such a important feauture isn´t working correctly. Maybe I am doing something wrong.

There are sometimes issues based on if you are in  a an IF or a LOOP.  Granted, this functionality should still work. Like last time, try another action preceding your error action that say “if this, then GO TO LABEL”

 

good luck

Adrian_AUT
Frequent Visitor

I already tried it, exactly thats the plan. If there is an error, GO TO LABEL. But sadly there is the problem it, can´t find the labels. I tried to Jumt to a label (cant be found) or to a subflow both options doesn´t work.

It seems label only works IN one loop, but not in the whole subflow/flow.

EDIT: Just to clarify because it was markted as solution. It is still a BUG! in my opinion. It has to be a solution that i can use a Label over the whole projekt, or at least in the same flow!

I tried to replicate the original example: a switch case inside of a for each, and I can't.  The loops are always available for me.  Try this:

Make your action and your Label Outside of the Loop, set up the error, and then move the actions into their appropriate places.

waynewu
Regular Visitor

I have another potential workaround, as following

1. Place the goto action right below the label

2. Open the goto action, select the label, save the goto action, and save & close the goto action block

3. Drag the goto action to the correct place you want it to be

This works for me. Hope this helps

ViliBit
Advocate II
Advocate II

Version 2.27 (December 2022) and the bug is still present.

I tried @waynewu  workaround. Is working beautifully and it looks even more elegant.

It should be marked as a second solution.

Helpful resources

Announcements
Power Automate News & Announcements

Power Automate News & Announcements

Keep up to date with current events and community announcements in the Power Automate community.

Community Calls Conversations

Community Calls Conversations

A great place where you can stay up to date with community calls and interact with the speakers.

Power Automate Community Blog

Power Automate Community Blog

Check out the latest Community Blog from the community!

Top Solution Authors
Top Kudoed Authors
Users online (5,812)