cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Nived_Nambiar
Resolver III
Resolver III

Issue in adding UI ELEMENTS in Power Automate Desktop

Hi all,

 

Hope everyone is fine 🙂

I am facing one issue in PAD while adding UIELEMENTS, when i add UI Elements, the elements are highlighted & when used ctrl+left click, it is not added to UIELEMENTS in PAD, well it is happening for few elements 

 

Attaching a video to understand the issue better

 

Video- UIELEMENT Adding issue 

 

Would it be a bug ?

Kindly help to resolve this issue

 

@VJR  @Pstork1 

 

Thanks & Regards,

Nived N

 

 

 

19 REPLIES 19
KaranSomnathe
Helper I
Helper I

Hi @Nived_Nambiar ,

 

I have tested in my system and its working, its not a bug for sure.

 

Try reinstalling extension and restarting browser.

 

Regards,

Karan

KaranSomnathe
Helper I
Helper I

Hi @Nived_Nambiar ,

 

I have tested in my system and its working, its not a bug for sure.

 

Try reinstalling extension and restarting browser.

 

Regards,

Karan

Nived_Nambiar
Resolver III
Resolver III

Let me try reinstalling the browser extension and try again

xsoldiercloud
New Member

So this started happening to me with the August release of the software I reverted back to my older version that I had in my downloads folder and the ctrl + click functionality came back. What version of power automate do you have installed? 

 

I have the issue on 2.23.114.22217, but when I install the older 2.22.263.22202 version everything works as intended. I read somewhere on these forums to try an older version and sure enough that did the trick. Any MS employee that can confirm this bug and if its going to be addressed in future versions? 

Nived_Nambiar
Resolver III
Resolver III

Hi @xsoldiercloud 

 

Yes i am using the version 2.23.114.22217 , seems like this is a bug, 

 

Is it possible we can go back to older version, i don't have old version installer in my system 

 

Also how to let microsoft team to know this issue ?

 

Thanks & Regards,

Nived N

Nived_Nambiar
Resolver III
Resolver III

Anyone know how to get the older version of ms power automate

 

still facing the same issue 

 

@VJR  @Pstork1 

 

 

Hi @Nived_Nambiar 

 

- Did you try it on any other machine and does it produce the same issue? This will help to identify a few things.

- Is this URL public that you can share here for anyone to take a look at? (external Onedrive video is blocked at my place).

 

 

 

 

Nived_Nambiar
Resolver III
Resolver III

Hi @VJR 

 

No, i am not able to try in another machine as this is for learning purposes

 

well, you can have look at url 

 

https://excelcult.com/QuizApp/end.html

 

 

I think it seems to be bug as earlier reponses to this query is like that

 

 

I have experienced this before with some web pages. 

Probably because this is just a pure .html page as seen in the URL.

Your options are to use the recorder and then go to the UI elements tab to check the elements and then access them.

 

VJR_0-1665133137014.png

 

VJR_1-1665133167528.png

 

 

 

 

Hi @VJR 

 

Thank you for teh suggestions

 

well, when i tried to access the webpage in edge instead of chrome, ui elements were highlighted once, but after that it is not highlighted after that.

 

Also Wait for element seems to be stuck for a longer period of time than the timeout, in case element is present in webpage.

 

Do you think this is the bug with latest update ?

 

 

Nived_Nambiar
Resolver III
Resolver III

@VJR 

 

Adding one more point,

 

i tried recorder now and still not working , the typing name into that field is not recorded in recorder.

 

 

Ok, Edge also worked fine using the above mentioned approach.

VJR_0-1665139397547.png

 

But don't think it as a bug in this update as I have encountered the same in previous versions (it was a html page).

We'll come to know if that is the case if we see more and more members experiencing the same.

 

Nived_Nambiar
Resolver III
Resolver III

Not working for me in edge as well 😞

Are you using the Recorder approach suggested above?

 

Try this:

Start Recorder

Type hello (wait for a few seconds) Press tab. This does not show the input typing in the recorder yet.

Click button. This now shows the typing and the click button together on the recorder window.

 

 

Nived_Nambiar
Resolver III
Resolver III

Hi @VJR 

 

After started to record, it is not aloowing to type in input field 

 

 

LogicSmith
Resolver I
Resolver I

I have found that I have the most issues capturing UI elements if the browser is full-screen. If I try to capture and cannot see browser contents, I switch to non-full-screen and can capture fine. I don't remember which browser(s) this seems to be an issue with as I use all three.

Nived_Nambiar
Resolver III
Resolver III

Hi @LogicSmith ,

Thank you for the reply, but still it is not working

 

I think this is a kind of bug with respect to power automate desktop in identifying ui elements

LogicSmith
Resolver I
Resolver I

I have occasionally hit pages or elements that I could not capture as a standard or web UI element. In those cases, I've usually had adequate luck with images. It helps to capture the image several times, using multiple browsers and/or operating systems, then you can have it look for the group of them and click there. PAD doesn't do image handling as well as Eggplant does, but it can be useful.

Jamar_Forsythe
Microsoft
Microsoft

I know this is the typical support question, but have you tried uninstalling and reinstalling both the app and extension? Are you getting the same issue with Edge or Firefox? Try capturing an element from the recorder, also try capturing an element from the Elements Pane (click on the Add UI Element Button and capture something in the browser)

Jamar_Forsythe_0-1665945393443.png

 

Helpful resources

Announcements
Power Automate News & Announcements

Power Automate News & Announcements

Keep up to date with current events and community announcements in the Power Automate community.

Power Automate Community Blog

Power Automate Community Blog

Check out the latest Community Blog from the community!

Top Solution Authors
Top Kudoed Authors
Users online (8,171)