cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
rso206
Regular Visitor

Needing to re add UI elements to get previous ones working

I am having a strange issue that I have been trying to figure out for hours.  I have an action to click on a UI Element (Element 1) which works once. The next time I run the flow it cannot find the element (Element 1) on the page.  If I were to duplicate the action and create a new UI element (Element 2) the previous (Element 1) one would start working again. This happens over and over. I went in to each element and they are identical so why would recreating make the previous one work.  

 

Thanks!

2 REPLIES 2
momlo
Responsive Resident
Responsive Resident

Hi @rso206 ,

Well, you have just entered the world or RPA, and discovered that Web and UI elements are not static and often change every time you refresh page.

 

You need to learn what "selectors" are, and then how to make them "dynamic" meaning they still specific enough that they point to the element you want to manipulate with, but are dynamic enough to accommodate changing attributes.

 

Search the forum, watch YouTube on "selectors" and "dynamic selector" 🙂

Thanks for the advice. I'll look in to those topics.

Helpful resources

Announcements
Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Top Kudoed Authors
Users online (2,583)