cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
robofski
Helper II
Helper II

No PowerShell window

Just wondering if I'm missing something but I have a simple PAD flow that executes a PowerShell script that is passed as a parameter from a Cloud Flow however I don't see the PowerShell window open.  The script executes and I see an instance of PowerShell running in Task Manager but unlike the previous version of UI flows I don't actually see the window open.

Like I say everything works but it was just confusing that the window didn't actually open!

1 ACCEPTED SOLUTION

Accepted Solutions
RPA2
Microsoft
Microsoft

Hi There,

This is an expected behavior of PAD. When you run a PowerShell Script, it does not open the PowerShell Window, but it runs the program. The "Run DOS Command" and "Open CMD Session" Actions in PAD also show similar behavior. The "Open CMD Session" Action opens a CMD session in the background and runs all the command written to that session. You can read the session output as well, with no interaction with the CMD Window, till the session is alive.
This RPA feature enables Users to carry on with other tasks while the BOT is busy running Desktop Flows in the background.

I hope this makes sense.

Thanks!

 

View solution in original post

4 REPLIES 4
RPA2
Microsoft
Microsoft

Hi There,

This is an expected behavior of PAD. When you run a PowerShell Script, it does not open the PowerShell Window, but it runs the program. The "Run DOS Command" and "Open CMD Session" Actions in PAD also show similar behavior. The "Open CMD Session" Action opens a CMD session in the background and runs all the command written to that session. You can read the session output as well, with no interaction with the CMD Window, till the session is alive.
This RPA feature enables Users to carry on with other tasks while the BOT is busy running Desktop Flows in the background.

I hope this makes sense.

Thanks!

 

Makes perfect sense thank you for clarifying. 

@robofski Does the PS1 actually execute what is expected from it? I have the same scenario, PAD says it executed the PS1 file, no errors, yet nothing happen as if nothing was executed.
Execute the same PS1 directly from elevated PS Shell works fine. I'm puzzled!

My PS1 commands are executed as expected. 

Helpful resources

Announcements
 WHAT’S NEXT AT MICROSOFT IGNITE 2022

WHAT’S NEXT AT MICROSOFT IGNITE 2022

Explore the latest innovations, learn from product experts and partners, level up your skillset, and create connections from around the world.

Register for a Free Workshop.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Top Solution Authors
Users online (1,940)