cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
nehaira
Frequent Visitor

PAD Can Detect UI Element on One System but Not Another

Hi All,

 

I have a flow which needs to interact with a SPA with an iframe embedded in it. Due to security permissions and how the website was designed, I cannot simply right click and open the iframe in a new tab to interact with the elements. After reading several other posts, I was eventually able to detect a text box and the elements of a table in the iframe using UI Automations (Populate Text Field in Window and Click UI Element in Window). 

 

I developed this flow on a Windows Virtual Desktop and have been able to run it since January with no issues. When I tried to move the flow from my WVD to a Windows Server, however, PAD can no longer pick up the UI elements within the iframe. No other users who have tried the flow on other WVDs can detect the elements either. I've tried Browser and UI Automations and the Recorders to see if I could remap the fields but have had no success. I've checked configurations of the components involved (PAD, browser, other WVDs, etc.) and cannot spot any obvious differences. Does anyone have any insight on why this could be happening and how I could resolve this?

 

Thank you.

0 REPLIES 0

Helpful resources

Announcements
 WHAT’S NEXT AT MICROSOFT IGNITE 2022

WHAT’S NEXT AT MICROSOFT IGNITE 2022

Explore the latest innovations, learn from product experts and partners, level up your skillset, and create connections from around the world.

Register for a Free Workshop.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

September Events 2022

Check out all of these events

Attend in person or online, there are incredible conferences and events happening all throughout the month of September.

Top Solution Authors
Top Kudoed Authors
Users online (3,343)