cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
realbluesky
Regular Visitor

PAD Live Web Helper doesn't do anything in Chrome

Hi - Total PAD noob here. Tech savvy but not a web dev. Trying to get started extracting data from a Chrome page.

 

I have Installed Chrome extension and re-booted. Extension icon is blue.

 

I'm in the "Extract data from a web page" interface, and my instance is selected. When I click into the page (or any webpage) the Live Web Helper pops up as it should.

 

However, I don't get any interaction, like frames being outlined or elements being recognized on mouseover or selection, nothing. When I right click elements I just get their usual Chrome right click options. Something is clearly not connected.   

 

Help?

2 ACCEPTED SOLUTIONS

Accepted Solutions

Thanks. I figured out the problem.

 

I have two different Chrome profiles (work & home) running at the same time. My flow needed to connect to an open "work" webpage, and I told PAD to attach to the page "by title", and manually populated the title to join to.

 

What I didn't realize was that it was never connected, and I gave up on Chrome and got it to work in Edge.

 

Now, smarter, I went back to Chrome and can see that PAD was only recognizing open pages on my "home" profile. When I opened the page under my "home" Chrome profile, I was able to actually select the page title from the dropdown, and achieve a connection and properly select page elements.

 

Three things I learned which might help somebody:

(1) PAD is seriously lacking in the user-friendly department. It should indicate (for web connections) that (a) selecting from the dropdown is required, and (b) whether or not connection has been achieved.

(2) PAD only seems to recognize one open Chrome profile, so if you have two open profiles and its not working, try the other one.

(3) When I tried to work on my second monitor, the highlighted page elements were out of sync with my mouse position. Working on the laptop monitor fixed the issue (might have been able to also solve it by making the second monitor primary.)

View solution in original post

Note: I found that if you have Windows 10 Business, that actually means you have "Pro" for the purposes of PAD prerequisites. This is an oversimplification of the case, if anybody feels the need to expand on it go right ahead. 🙂

View solution in original post

4 REPLIES 4
realbluesky
Regular Visitor

OK. maybe this is the problem...

 

I am running: Windows 10 Business

the prerequisites are: Windows 10 Home, Windows 10 Pro, Windows 10 Enterprise, Windows Server 2016, or Windows Server 2019.

 

So am I just out of luck?

 

VJR
Super User
Super User

Hi @realbluesky 

 

I am using Win 10 Home, the one from the list, but still face this issue sometimes.

It requires doing it multiple times.

 

Are you using the "Add UI element" from the right hand side

or using the Web Recorder button on the top?

 

If one does not work then choose the other and vice versa.

 

Also are you looking at any specific website so that I can try out and see if its got to do something with the way the webpage is built or an issue with PAD?

Thanks. I figured out the problem.

 

I have two different Chrome profiles (work & home) running at the same time. My flow needed to connect to an open "work" webpage, and I told PAD to attach to the page "by title", and manually populated the title to join to.

 

What I didn't realize was that it was never connected, and I gave up on Chrome and got it to work in Edge.

 

Now, smarter, I went back to Chrome and can see that PAD was only recognizing open pages on my "home" profile. When I opened the page under my "home" Chrome profile, I was able to actually select the page title from the dropdown, and achieve a connection and properly select page elements.

 

Three things I learned which might help somebody:

(1) PAD is seriously lacking in the user-friendly department. It should indicate (for web connections) that (a) selecting from the dropdown is required, and (b) whether or not connection has been achieved.

(2) PAD only seems to recognize one open Chrome profile, so if you have two open profiles and its not working, try the other one.

(3) When I tried to work on my second monitor, the highlighted page elements were out of sync with my mouse position. Working on the laptop monitor fixed the issue (might have been able to also solve it by making the second monitor primary.)

Note: I found that if you have Windows 10 Business, that actually means you have "Pro" for the purposes of PAD prerequisites. This is an oversimplification of the case, if anybody feels the need to expand on it go right ahead. 🙂

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

New Ideas Forum MPA.jpg

A new place to submit your Ideas for Power Automate

Announcing a new way to share your feedback with the Power Automate Team.

Carousel_PP_768x460_Wave2 (1).png

2022 Release Wave 2 Plan

Power Platform release plan for the 2022 release wave 2 describes all new features releasing from October 2022 through March 2023.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

365 EduCon 768x460.png

Microsoft 365 EduCon

Join us for two optional days of workshops and a 3-day conference, you can choose from over 130 sessions in multiple tracks and 25 workshops.

Top Solution Authors
Top Kudoed Authors
Users online (3,356)