cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
MoodyWebTech
Regular Visitor

PAD - Open Browser in Incognito Mode

Hello,

Is there any way to open a Browser in Incognito mode?

I was able to do it only by using a "Run Application" activity, adding the argument "--incognito."

The problem with this is that when I try to use a "Launch new Chrome" with the option "attach to running instance," the browser is not recognized by PAD.

 

Thank you

1 ACCEPTED SOLUTION

Accepted Solutions
matow
Power Automate
Power Automate

@MoodyWebTech Try these steps - there's an extra setting needed to enable the Chrome extension "Microsoft Power Automate Desktop (preview)" in Incognito mode, and "Launch new Chrome" needs the name of the Incognito tab (typically "new tab") to attach to the running instance.

 

  1. Visit chrome://extensions and click "Details" for the "Microsoft Power Automate Desktop (preview)" extension, and turn on the "Enable in Incognito" setting towards of the bottom of the page. 
  2. In your flow in Power Automate Desktop, after the action Run Application with argument "--incognito", add a Launch New Chrome step with Launch mode as "Attach to running instance", Attach to Chrome tab as "By title"Tab title as "new tab", and On error as "Retry if an error occurs 1 time(s) with an interval of 2 second(s). It seems around a 1 or 2 second delay is needed between the Run Application and Launch New Chrome actions - this may need to be adjusted for slower computers. 
  3. You should then see the Browser variable populate when the flow is run. 

View solution in original post

8 REPLIES 8
matow
Power Automate
Power Automate

@MoodyWebTech Try these steps - there's an extra setting needed to enable the Chrome extension "Microsoft Power Automate Desktop (preview)" in Incognito mode, and "Launch new Chrome" needs the name of the Incognito tab (typically "new tab") to attach to the running instance.

 

  1. Visit chrome://extensions and click "Details" for the "Microsoft Power Automate Desktop (preview)" extension, and turn on the "Enable in Incognito" setting towards of the bottom of the page. 
  2. In your flow in Power Automate Desktop, after the action Run Application with argument "--incognito", add a Launch New Chrome step with Launch mode as "Attach to running instance", Attach to Chrome tab as "By title"Tab title as "new tab", and On error as "Retry if an error occurs 1 time(s) with an interval of 2 second(s). It seems around a 1 or 2 second delay is needed between the Run Application and Launch New Chrome actions - this may need to be adjusted for slower computers. 
  3. You should then see the Browser variable populate when the flow is run. 

It worked! Thank you.

MoodyWebTech
Regular Visitor

@matow this solution is no longer working with Chrome. Do you know if there has been an update in PAD that may have affected the connection with the browser in incognito mode?

Karrar
New Member

 

This Works 100% 

 

https://www.youtube.com/watch?v=bmVm42RHjB8

 

Hope This Helps.

Hi, have you managed to find a solution to this? I am getting the incognito window opened, but the website is not getting launched. I am getting error as below:
Failed to assume control of Chrome (communication with browser failed. Make sure add-on is installed).

Extension is already installed and configured for incognito.

@matow Can you help me out please?

Amith444_0-1656039632451.pngAmith444_1-1656039650186.png

 

 

 

@Amith444 As an additional troubleshooting step, can you confirm that Edge is configured to allow background apps per Using browsers and managing extensions - Power Automate | Microsoft Docs

 

To ensure that Microsoft Edge works as expected with Power Automate, disable running background apps when Edge is closed.

To disable this option, navigate to Settings -> System and select the slider next to Continue running background apps when Microsoft Edge is closed.

 

 

matow_2-1656039880425.png

 

 

 

Amith444_0-1656040613094.png

 

Amith444_1-1656040641051.png

Failed to assume control of Microsoft Edge (is the given title '"New tab"' a valid title?).

 

Getting this error in Edge.

 

Amith444_2-1656040721877.png

This is the incognito opening in edge.

@matow Once I changed the Tab title to New tab (without quotes) it worked! But may I ask, how can I pass my desired url to Open in this incognito window? I cannot see a option to pass the url or type the url.

 

Amith444_0-1656041448539.png

 

Helpful resources

Announcements
Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Top Kudoed Authors
Users online (3,780)