cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Lazar1
Regular Visitor

PAD cannot recognize UI element on web page

hi,

I want to get data from a web page,

I use first the Launch new Edge action and this goes right to the typed url.

But when trying to use action Click on a link or any other element from a web, I cannot add a UI element (the add on is also installed on my browser), as PAD doesn't recognize anything if I hover the mouse on the web page.

I tried even with only one monitor.

Also tried from recorder and there is only one Recorder button but not those tow distinct with desktop & web record - I do have a user license, could all of this be due to license ?

 

thank you in advance,

2 ACCEPTED SOLUTIONS

Accepted Solutions
dominikmad
Advocate I
Advocate I

That can happen, try the following:
Try it with Chrome

Try it with the function "click on link on website" instead of the "click on UI element" or the other way around... sometimes the website is built like that

If none of that works, tell me what website it is so i can test it

 

Hope i was able to help!

View solution in original post

hi, i have tried again, now it is running for 20 min w/o error but no action from step 4 forward...

i have no idea what is wrong...seems to me that the actions i used are proper ones...

any other solution?

can i call you on teams? 

View solution in original post

16 REPLIES 16
dominikmad
Advocate I
Advocate I

That can happen, try the following:
Try it with Chrome

Try it with the function "click on link on website" instead of the "click on UI element" or the other way around... sometimes the website is built like that

If none of that works, tell me what website it is so i can test it

 

Hope i was able to help!

Ankesh_49
Power Participant
Power Participant

@Lazar1  Could you please try Send keys Tab and Enter. 

Cheers,

Ankesh

--------------------------------

If this post helps answer your question, please click on “Accept as Solution” to help other members find it more quickly. If you thought this post was helpful, please give it a Thumbs Up.

 

hi, 

with chrome seems to go well, at least it recognize some UI elements on web.

but I still have issues with the flow on web as it moves quickly from a action step to the next and skip some actions, it doesnt perform all, and get fails errors... it is a company site, with credentials for log into, so you couldnt text it..

thank you for your help.

Ankesh_49
Power Participant
Power Participant

Use delay between actions or wait for element to appear.

hi,

thank you, I did as you suggested, and get rid of fails error due to delay.

but I have still some steps/actions that are skipped by the flow...

steps 5&6 are skipped: 

Lazar1_0-1655995166946.png

do you have any idea on this? 

Ankesh_49
Power Participant
Power Participant

@Lazar1  Would you mind trying below:

 

Open the action and click 'on error'

Ankesh_49_0-1655995887787.png

 

Enable retry action, increase the interval as well

 

Ankesh_49_0-1655995990717.png

 

Let me know in case of any issue.

 

Cheers,

Ankesh

--------------------------------

If this post helps answer your question, please click on “Accept as Solution” to help other members find it more quickly. If you thought this post was helpful, please give it a Thumbs Up.

 

 

 

 

Ankesh_49
Power Participant
Power Participant

@Lazar1 any luck?

 

Cheers,

Ankesh

--------------------------------

If this post helps answer your question, please click on “Accept as Solution” to help other members find it more quickly. If you thought this post was helpful, please give it a Thumbs Up.

not yet. 

i will try tomorrow again.

thanks for helping.

Ankesh_49
Power Participant
Power Participant

Sure. Looking forward to the outcome.
As we can try few other logic, if the above is not yielding any good.

Thanks

Ankesh 

hi, i have tried again, now it is running for 20 min w/o error but no action from step 4 forward...

i have no idea what is wrong...seems to me that the actions i used are proper ones...

any other solution?

can i call you on teams? 

Ankesh_49
Power Participant
Power Participant

@Lazar1 Sure. lets connect

how can i contact you?

Ankesh_49
Power Participant
Power Participant

Please check your message inbox

Ankesh_49
Power Participant
Power Participant

Lets have a teams connect

Ankesh_49
Power Participant
Power Participant

@Lazar1  Hope you are able to proceed ahead and our teams connect was fruitful.

Cheers,

Ankesh

--------------------------------

If this post helps answer your question, please click on “Accept as Solution” to help other members find it more quickly. If you thought this post was helpful, please give it a Thumbs Up.

Ankesh_49
Power Participant
Power Participant

 

@Lazar1  You can mark multiple solutions, if it helps!!

Cheers,

Ankesh

--------------------------------

If this post helps answer your question, please click on “Accept as Solution” to help other members find it more quickly. If you thought this post was helpful, please give it a Thumbs Up.

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

New Ideas Forum MPA.jpg

A new place to submit your Ideas for Power Automate

Announcing a new way to share your feedback with the Power Automate Team.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

MPA Licensing.jpg

Ask your licensing questions at the Power Automate AMA!

Join Priya Kodukula and the licensing team, super users and MVPs to find answers to your questions on Power Automate licensing.

Top Kudoed Authors
Users online (1,740)