cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Rkmatieda
Helper I
Helper I

PAD software working terribly slow and Hangs at times

Dear Admins,

Please consider this feedback regarding Power Automate Desktop being terribly slow while creating the flows. It hangs many times, throws the error strings, and working with different panes (variable, activities, sub flows selections) is very troublesome because you will have to wait for few seconds till the other sub flow window opens after clicking on their tabs.

 

Also, this is peculiar because such behavior doesn't happen when you just start your computer and work with software. after some time, the slowness comes in effect. As a remedy you must restart the computer. And please note I don't have under capacity system, it has i7 processor and 32 gigs of RAM. 

 

However, also note that when I run the flow it is absolutely fine. I mean even though having written some heavy code it works perfactly ok. I have no problem in doing debuging of the code as well. It is just a problem in the flow development environment.

 

 

15 REPLIES 15
ChristianAbata
Super User II
Super User II

hi @Rkmatieda  could you try downloading the last version? its has a better performance. I'm working now with 8Gb RAM and i5 pc



Did I answer your question? Please consider to Mark
my post as a solution! to guide others :winking_face:

Proud to be a Flownaut!


If you want you can follow me at www.christianabata.com Quieres contenido en español? Síguenos en Power Automate LA

Hi @ChristianAbata ,

I did it. but only marginal increase in response. 

The problem is that when you start the software, it works properly but after certain time it starts lagging in response. but the good part is that ever after such slow response it doesn't hang and stop responding.

csundar
Resolver I
Resolver I

@Rkmatieda  I have found that closing my flows and the desktop application and restarting it helps with this issue.  Also if I have many browser windows open it seems to add delay.  I suspect it is related to the connections between PAD and the browser plugins.

sakula1996
Responsive Resident
Responsive Resident

@Rkmatieda , I agree. 

As flow gets bigger, PAD gets slower.

Tip: For faster run, try running it from the flows window

sakula1996_0-1609956549982.png

 

yoko2020
Frequent Visitor

Tried with PAD latest version, and the issue still there.

It still need improvement. Winautomation and ProcessRobot engine more responsive and faster.

Our time will be wasted if we build a complex process which contain many function.

 

ps : i am using high end laptop

AMD Ryzen™ 9 4900H Processor 3.3 GHz (8M Cache, up to 4.4 GHz)

NVIDIA® GeForce® RTX 2060 with ROG Boost

- 16 GB DDR4 3200Mhz

 

ChristianAbata
Super User II
Super User II

@yoko2020 sure a kind of improve could come in the future.



Did I answer your question? Please consider to Mark
my post as a solution! to guide others :winking_face:

Proud to be a Flownaut!


If you want you can follow me at www.christianabata.com Quieres contenido en español? Síguenos en Power Automate LA
miketran13
Solution Specialist
Solution Specialist

I totally agreed, It is so slow. I could not believe a public version could slow like that. 

If my flow is simple, then it is ok. But if my flow is getting complicated with more actions and sub flows. Then it is terribly slow, and I have to wait for 5-10 seconds for any actions on PAD. The PAD process takes all the CPU. 

I hope the team can fix it ASAP.

Regards,

Mike

PAPerformance.png

emilyh
Regular Visitor

I have the same issue. When adding more and more actions to the flow, then it becomes super slow, adding every action or just scroll up and down takes seconds to complete. Wasting too much time for just waiting. The issue should be taken care of asap.

Please!!! 

Shane147
Frequent Visitor

I hate to add to the chain of complain, but anyone comparing the speed of the PAD editor vs. WinAutomation editor will be very disappointed at the moment.   I do hope MS manage to sort this out.   I thought it maybe just my setup, but it's borderline unusable if you are building complex flows. 

Agree, It is not individual issue. Everybody experiencing this slowness in their machine.

joshd111
Resolver I
Resolver I

I used to have this problem, using the December release. Task Manager would show PAD using an holding memory: basically a memory leak. This would lead to great slowness in the ability to edit the flows. 

 

Since I downloaded the latest install package which is version 2.3.45.21021, the problems have gone away. PAD feels very snappy now. Good work Microsoft!

yoko2020
Frequent Visitor

Tested with latest version. Looks like the problem has gone. Will keep monitoring if there is an issue again.

aagirre92
Frequent Visitor

Hi, I am working with the latest version (.69) and this problem seems to continue. I am having serious performance issues with simple flows

When do you see the performance issues?

aagirre92
Frequent Visitor

Can't tell a pattern, but some flow edition in PAD are quite tedious as performance is not good (I frequently have to End task)

Helpful resources

Announcements
MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MSFTBizAppsLaunchEvent

Experience what’s next for Power Virtual Agents

See the latest Power Automate innovations, updates, and demos from the Microsoft Business Applications Launch Event.

New Super Users

Meet the Power Automate Super Users!

Many congratulations to the Season 1 2021 Flownaut Crew!

Power Platform ISV STudio

Power Platform ISV Studio

ISV Studio is the go-to Power Platform destination for ISV’s to monitor & manage applications post-AppSource publish.

Users online (39,735)