cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Helper I
Helper I

PAD software working terribly slow and Hangs at times

Dear Admins,

Please consider this feedback regarding Power Automate Desktop being terribly slow while creating the flows. It hangs many times, throws the error strings, and working with different panes (variable, activities, sub flows selections) is very troublesome because you will have to wait for few seconds till the other sub flow window opens after clicking on their tabs.

 

Also, this is peculiar because such behavior doesn't happen when you just start your computer and work with software. after some time, the slowness comes in effect. As a remedy you must restart the computer. And please note I don't have under capacity system, it has i7 processor and 32 gigs of RAM. 

 

However, also note that when I run the flow it is absolutely fine. I mean even though having written some heavy code it works perfactly ok. I have no problem in doing debuging of the code as well. It is just a problem in the flow development environment.

 

 

12 REPLIES 12
Super User II
Super User II

hi @Rkmatieda  could you try downloading the last version? its has a better performance. I'm working now with 8Gb RAM and i5 pc



Did I answer your question? Please consider to Mark
my post as a solution! to guide others :winking_face:

Proud to be a Flownaut!


If you want you can follow me at www.christianabata.com Quieres contenido en español? Síguenos en Power Automate LA

Hi @ChristianAbata ,

I did it. but only marginal increase in response. 

The problem is that when you start the software, it works properly but after certain time it starts lagging in response. but the good part is that ever after such slow response it doesn't hang and stop responding.

Helper I
Helper I

@Rkmatieda  I have found that closing my flows and the desktop application and restarting it helps with this issue.  Also if I have many browser windows open it seems to add delay.  I suspect it is related to the connections between PAD and the browser plugins.

Helper V
Helper V

@Rkmatieda , I agree. 

As flow gets bigger, PAD gets slower.

Tip: For faster run, try running it from the flows window

sakula1996_0-1609956549982.png

 

Frequent Visitor

Tried with PAD latest version, and the issue still there.

It still need improvement. Winautomation and ProcessRobot engine more responsive and faster.

Our time will be wasted if we build a complex process which contain many function.

 

ps : i am using high end laptop

AMD Ryzen™ 9 4900H Processor 3.3 GHz (8M Cache, up to 4.4 GHz)

NVIDIA® GeForce® RTX 2060 with ROG Boost

- 16 GB DDR4 3200Mhz

 

Super User II
Super User II

@yoko2020 sure a kind of improve could come in the future.



Did I answer your question? Please consider to Mark
my post as a solution! to guide others :winking_face:

Proud to be a Flownaut!


If you want you can follow me at www.christianabata.com Quieres contenido en español? Síguenos en Power Automate LA
Solution Supplier
Solution Supplier

I totally agreed, It is so slow. I could not believe a public version could slow like that. 

If my flow is simple, then it is ok. But if my flow is getting complicated with more actions and sub flows. Then it is terribly slow, and I have to wait for 5-10 seconds for any actions on PAD. The PAD process takes all the CPU. 

I hope the team can fix it ASAP.

Regards,

Mike

PAPerformance.png

Regular Visitor

I have the same issue. When adding more and more actions to the flow, then it becomes super slow, adding every action or just scroll up and down takes seconds to complete. Wasting too much time for just waiting. The issue should be taken care of asap.

Please!!! 

Frequent Visitor

I hate to add to the chain of complain, but anyone comparing the speed of the PAD editor vs. WinAutomation editor will be very disappointed at the moment.   I do hope MS manage to sort this out.   I thought it maybe just my setup, but it's borderline unusable if you are building complex flows. 

Agree, It is not individual issue. Everybody experiencing this slowness in their machine.

Resolver I
Resolver I

I used to have this problem, using the December release. Task Manager would show PAD using an holding memory: basically a memory leak. This would lead to great slowness in the ability to edit the flows. 

 

Since I downloaded the latest install package which is version 2.3.45.21021, the problems have gone away. PAD feels very snappy now. Good work Microsoft!

Frequent Visitor

Tested with latest version. Looks like the problem has gone. Will keep monitoring if there is an issue again.

Helpful resources

Announcements
Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

New Super Users

Meet the Power Automate Super Users!

Many congratulations to the Season 1 2021 Flownaut Crew!

Microsoft Ignite

Microsoft Power Platform: 2021 Release Wave 1 Plan

Power Platform release plan for the 2021 release wave 1 describes all new features releasing from April through September 2021.

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Top Solution Authors
Users online (20,000)