cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
AndrePowerAutom
New Member

Problem with Power Automate Destop

Hey,

I´m from germany so sorry for my bad english 🙂

I want to build a flow which gets as input a list of numbers from a csv. For each number I have defined a action in a ERP program.
The loading of the CSV works fine. Even the for each function as itself works fine.

But when I try to use the function "Filling textfield in window" with the numbers of the CSV I get the error message, that the argument "text" needs to be encrypted.

I filled it with that: %CurrentItem%

When I change the setting to "secret text" the program writes the text %CurrentItem% instead of the number I want to have.

What am I doing wrong? Do I use the wrong function?


Thank you already.


Andre

1 ACCEPTED SOLUTION

Accepted Solutions
AndrePowerAutom
New Member

I got it... the standard value is text. I had to declare it as variable that it is accepted.

 

Thanks you guys.

View solution in original post

7 REPLIES 7
fraenK
Memorable Member
Memorable Member

Looks like a type mismatch (text vs. numbers?) between source and target. Maybe that helps: https://powerusers.microsoft.com/t5/Power-Automate-Desktop/Argument-Text-Must-be-Encrypted-value-pop...

sakula1996
Responsive Resident
Responsive Resident

@AndrePowerAutom  are you trying to write entire csv row to the erp app, or a specific cell from CSV.

Is it possible for you to show the structure of your csv file and the powerautomate actions you're using?

 

Thanks

AndrePowerAutom
New Member

@fraenK 

I guess you are right. I found that information in the post you showed me:
"Thank you for your help, I found that the input type accepts only number because of that it was not able to enter the value, so I tried converting it as txt to number, then it was able to enter the value into the field."

But I dont get how to do that.

@sakula1996 
My test csv has only 1 row with the number 291148384.

Here is how is setted up. 

 

WhatsApp Image 2021-03-18 at 17.08.06.jpeg

AndrePowerAutom
New Member

I got it... the standard value is text. I had to declare it as variable that it is accepted.

 

Thanks you guys.

View solution in original post

You shouldn't need a dedicated variable if you just convert the current item to a number before it's entered into the field: https://docs.microsoft.com/de-de/power-automate/desktop-flows/actions-reference/text#tonumber

But how can I do that? When I write 

FormattedNumber(%CurrentItem%)

it doesnt format it. it just writes the text like this:
FormattedNumber(291148384)

 

I even setted it in the csv file as text. Is there a special syntax?

Oh man shame on me... Now I finally found 😅 Thanks xD

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

V3_PVA CAmpaign Carousel.png

Community Challenge - Giveaways!

Participate in the Power Virtual Agents Community Challenge

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Users online (2,806)