cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Shann
Regular Visitor

Send Keys is populating the text box as {tab} instead of performing the tab function

I have a Microsoft Navigate form I'm working on populating and some of the text fields on a page are failing to be found when using Populate Text. To navigate this I am attempting to tab to the correct boxes by using Send Keys and {tab} from another working text box. Depending on the text box field, sometimes it tabs over and sometimes it populates the {tab:3} or whatever else as Text instead. 

 

I definitely have Send Keys as Hardware Text selected.

 

Any suggestions?

1 ACCEPTED SOLUTION

Accepted Solutions
MichaelAnnis
Super User
Super User

Read all of this first, as one of these may stick out to you. The last part is probably the most promising, but wanted to run through some other troubleshooting options first. 


1) try a capital T in {Tab}

 

2). Ensure there are no unidentified spaces anywhere such as {Tab }

 

3). Try turning off send as hardware keys. I have never had to use that and {Tab} has always worked just fine. 

4). Do the same ones always mess up?  If so, try copying one of the ones that is working and deleting the ones that are messing up


5)If none of that works, put a Wait(1) between the tabs and other send text. Sometimes PAD just runs over itself simply because it’s moving to fast. 

 

Lastly, is there another field that you can find after and {LShiftKey}({Tab}) back to the field you need?

 

Good luck!

View solution in original post

2 REPLIES 2
MichaelAnnis
Super User
Super User

Read all of this first, as one of these may stick out to you. The last part is probably the most promising, but wanted to run through some other troubleshooting options first. 


1) try a capital T in {Tab}

 

2). Ensure there are no unidentified spaces anywhere such as {Tab }

 

3). Try turning off send as hardware keys. I have never had to use that and {Tab} has always worked just fine. 

4). Do the same ones always mess up?  If so, try copying one of the ones that is working and deleting the ones that are messing up


5)If none of that works, put a Wait(1) between the tabs and other send text. Sometimes PAD just runs over itself simply because it’s moving to fast. 

 

Lastly, is there another field that you can find after and {LShiftKey}({Tab}) back to the field you need?

 

Good luck!

Shann
Regular Visitor

I'm not sure what aspect worked but I got it working! I also realized I was pointing to the "edit" portion of the text box, which should still work with the tab but moving it to the "group" portion of the box I think might have helped.

 

Thank you!

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

New Ideas Forum MPA.jpg

A new place to submit your Ideas for Power Automate

Announcing a new way to share your feedback with the Power Automate Team.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

MPA Licensing.jpg

Ask your licensing questions at the Power Automate AMA!

Join Priya Kodukula and the licensing team, super users and MVPs to find answers to your questions on Power Automate licensing.

Top Kudoed Authors
Users online (1,931)