cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jfk86d
Helper I
Helper I

UI element CSS Selector with variable not working for Ordinal

Hi,

I have a UI element that includes two variables as part of its CSS Selector. One is for the Type and the other is for the Ordinal. Resulting CSS is below.

 

button[Class="inline-button"][Type="%NewVar%"]:eq(%LoopIndex%)

 

I received the following error. The value for %NewVar% for Type is used, but the %LoopIndex% variable is not successful for the Ordinal. Is this a bug?

 

Element with selector 'button[Class="bg-transparent bn lh-solid pa0 sans-serif tc underline inline-button black pointer f6 ml1"][Type="button"]:eq(%LoopIndex%)' not found.

 

Thanks, 

John

1 ACCEPTED SOLUTION

Accepted Solutions
Henrik_M
Dual Super User
Dual Super User

No; needs to be to the left. Microsoft needs to hire someone who knows about user interfaces.

View solution in original post

4 REPLIES 4
Henrik_M
Dual Super User
Dual Super User

Variables in the selector only works with custom mode activated. Did you turn it on?

Hi @Henrik_M,

Thank you for your reply. I think I have it on. I left the circled item below turned on. Is that what you mean?

 

jfk86d_0-1642542614265.png

 

Henrik_M
Dual Super User
Dual Super User

No; needs to be to the left. Microsoft needs to hire someone who knows about user interfaces.

@Henrik_M , Thank you that solved it!

Helpful resources

Announcements
MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

PWREduCon768x460.png

Join us at PWR EduCon - A Power Platform Conference

Learn from the top Power BI, Power Apps, Power Automate & Power Virtual Agents experts!

Power automate tips 768x460 v2.png

Restore a Deleted Flow

Did you know that you could restore a deleted flow? Check out this helpful article.

Users online (3,668)