cancel
Showing results for 
Search instead for 
Did you mean: 

Send Email (V2) Preview does not add hyperlinks to email alerts

Hi All,

I haven't created a FLOW in a few weeks and I was SOOOO excited to finally see a true HTML editor in FLOW Smiley Happy  Its wonderful I do not need all HTML formating, but it lost the ability to add a hyperlink without the displaying the full path, causing me to have to bail and go back the original Send Email task and HTML 😞

 

 

I always add a link back to the list item in the alert so my users can do everything right from the email.

 

I added some text and the "Link To Item" Dynamic content, but it displayed as the actaul link nothing freindly to look at.

SendEmailV2_OOTB.jpg

Please click link to go to the item: https://Blah.sharepoint.com/Blah/_layouts/15/listform.aspx?PageType=4&ListId=d826e68c-7bf7-48ba-a585...

Your system removed the actiual HTML

 

I the tried to use the "Add a link" from the tool bar but there is no way to put the "Link To Item" in the hyperlink.  

 

I even went back to the old fashioned way and tried to add <A HREF=></A>.

 SendEmailV2_HREF.jpg

which results in :

<A HREF="https://Blah.sharepoint.com/Blah/_layouts/15/listform.aspx?PageType=4&ListId=d826e68c-7bf7-48ba-a585...">Please click here to go to the Item</A>

 

We need a way to create a nice looking Hyperlink in Send Email (V2).

It's almost there keep on working on FLOW!!

 

TIA,

Joe

Status: New
Comments
Microsoft
  1. Initialize a variable
  2. Set the variable to be the proper html w/ the anchor link:
    <span style=\"font-size: 11px\"><a href="[DYNAMIC URL VARIABLE HERE]">[DYNAMIC TEXT VARIABLE HERE]</a></span>
  3. Use this variable in your email
Advocate II

This is a very poor Implementation for such a important function. 

Frequent Visitor

I completely agree SchneidAIR. They'll be bringing back MySpace next with all this HTML. Is Tom the new CEO of Power Automate? 🤣

 

It's a very poor implementation. Especially as once HTML is implemented the normal email editor window can no longer be used.

Resolver I

@JonathanErmey , works for me, thank you.

Regular Visitor

@JonathanErmey - does the job, for now! Thanks.

This is the solution post 

Frequent Visitor

Hi @JonathanErmey  - indeed, it does the job...

But I had to dig deep through internet after a dozen of failed trials to find this article, and just to discover that the link button from the flow's interface is useless... and misleading... 😞