cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Error "Bad Gateway" Error 502 - Flow was running fine

I've created a PowerApp that uses flow to submit a simple form to a SP List. It was working fine but now I am getting a 502 Bad Gateway Error. Any Ideas? 

6 REPLIES 6
Highlighted
Community Support
Community Support

Re: Error "Bad Gateway" Error 502 - Flow was running fine

Hi @Jake-Harvey,

 

Would it be convenient for you to share the Flow running details in a screenshot?

Troubleshooting a flow

In addition, please check your connection settings under Microsoft Flow Connection page:

Manage connections in Microsoft Flow

For another try, delete the SharePoint action and then add it again to check out.

Regards

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Advocate III
Advocate III

Re: Error "Bad Gateway" Error 502 - Flow was running fine

I have the same issue. Any feedback on fix?

Highlighted
Anonymous
Not applicable

Re: Error "Bad Gateway" Error 502 - Flow was running fine

Same here, have had a number of flows running perfectly well until the end of last week. Very frustrating!

 

Not sure if it is due to Microsoft, internal servers, my flows or something else.

 

Has anyone had any luck with this?

Highlighted
Continued Contributor
Continued Contributor

Re: Error "Bad Gateway" Error 502 - Flow was running fine

I just realized that one of the flows I created, to add a 'Due Date' in a column based on the created date, has failed numerous times -- error being 'Bad Gateway'.  After selecting 'Resubmit', it functioned as intended.  However, for all the entries that were input prior to today, the column was never updated with the calculated date.  

 

I have another Flow that failed repeatedly after first running as intended.  Once I went in, opened the Flow in edit mode and resaved, it started working again.  

 

As I promote the features of Flow and implementation of the application, these continued issues make it a challenge.  Can you advise -- is this a system problem and is it being addressed?  If so, what should we users expect in regards to performace and stability?

Highlighted
New Member

Re: Error "Bad Gateway" Error 502 - Flow was running fine

Generally I've found this issue occours when you are tring to have the flow update the Sharepoint list when the destination is unable to accept the flow's output. 

 

In my own issues with this error the flow has tried to submit more than the number of characters that can be had in a single line of text in a sharepoint list.

Highlighted
Resolver I
Resolver I

Re: Error "Bad Gateway" Error 502 - Flow was running fine

I don't have the answer to this just yet but I just got this message under a very specific set of conditions and, interestingly enough, the different PowerApps "players" do not behave consistently.

 

I am working with a Flow that calls a SQL Server stored procedure that returns a set of "rows" to PowerApps as a collection.  Life is good, I put in different search combos and get 1-n records back and everything functions properly.  But, when I put in a perfectly valid search string combo that, perfectly validly, returns 0 records back I get two different behaviors.

 

So now I am off trying to learn first where this 502 error is being generated.  Is it coming from the stored proc (probably not, 0 records is an acceptable response although it may return a code that indicates that 0 records match the search criteria), the Flow (probably yes but which step, in which form and where can I "receive" it from to process it) or PowerApps (if it is being passed back from the Flow somehow, how to I capture it there and address it?).

 

Here is what I see in the Editing area of the Studio after the error:

No Rows Returned Error.jpg

 

1) on the Web-based "player" (both within the Studio and just in the player alone), I get no errors reported to the app user.

2) on the iOS-based "player" I get the error message displayed to the user.

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Top Kudoed Authors
Users online (8,204)