cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
bolin-stratus
Continued Contributor
Continued Contributor

Flow Running Inside a Power App Suddenly Stops Working - No Errors in Power App or Power Automate Flow

I have a Power App with a Flow triggered within the Power App that I created about six months ago and everything has been working fine until about a week ago. The Flow is triggered inside the Power Apps when a button is click and the button’s OnSelect property has FlowName.Run()

I have been troubleshooting this issue and IMO the Flow is never getting triggered within the Power App.  It's weird because there are no Power Apps errors or Flow errors, the run history simply indicates no Flows have been triggered in the past week even though I know the Power App has been run multiple times a day over the past week.  I am trying to avoid creating the Flow from scratch, but it is not showing up as shown below so I can’t add it.  
Shoutouts App No Flows listed.PNG
Any recommendations are greatly appreciated.

6 REPLIES 6
Expiscornovus
Super User
Super User

Hi @bolin-stratus,

 

Just to double check. Have you checked if the flow still exists and is it accessible with the account that you are using to update the Power App?

 

cloudflows_sharedwithme.png

@Expiscornovus - Thanks for your response. Yes, the flow exists and can be seen in Cloud Flows for the same account (my acct).  It looks like I'm gonna have to just create it again unless you have any ideas to try.  

Expiscornovus
Super User
Super User

Hi @bolin-stratus,

 

I wouldn't start from scratch. I would use the save as to make a copy of the current flow and just rename it.

 

saveas_option.png

 

And just to double check. Both the Power App and the cloud flow are stored in the same environment?

@Expiscornovus - Sorry for the slow response but I had another wk issue that took priority. 

I had to remove the Flow connection from the app, close the app, reopen and when I tried to connect to the original flow (SendEmail4Vars) it was not available to add even though that flow can clearly be seen in the same environment.

Next, I opened the Power App again and clicked on Action > Power Automate and started a new flow and saved as SendEmail4Vars3 (it opened Power Automate in a separate window), and completed the flow without errors. Back in Power Apps, I successfully completed adding the flow ref and there were no errors. 

However, I discovered the flow I just created and successfully named SendEmail4Vars3 was NOT listed in the DXC Production environment, the only environment I have used since the tenant was created over 2 years ago.  Below is a screenshot demonstrating I am working in the DXC Production env, that within Power Apps you can see that SendEmail4Vars3 is listed and connected to the "ButtonSubmit", yet SendEmail4Vars3 is missing from the DXC Production env.  

Summary:
1. Unable to add an existing Flow to my Power App even though the flow SendEmail4Vars is in the same environment.  All other flows in the environment are also missing from the Power Apps add a flow menu. 
2. When I created the new flow SendEmail4Vars3 (initiated from within Power Apps), and successfully saved it, I was able to add in to my Power App without issue. 
3.  The newly created flow SendEmail4Vars is completely missing from the DXC Production environment, yet it can be seen within the Power App when clicking Actions > Power Automate to add a new flow.
4.  There are no errors in Power Apps or Flow to indicate any issues.

5.  I have been using the same DXC Production env for over 2 years, exclusively and therefore have never worked in any other env.

Shoutouts App DXC Env Issues.PNG 

Expiscornovus
Super User
Super User

Hi @bolin-stratus,

 

That looks like strange behaviour. I haven't been able to reproduce that in my dev environment.

 

To troubleshoot you could use the Get-AdminFlow to list all existing flows and see were that flow is stored. That might give you some pointers on what is happening.

 

And is the new flow now triggering and working properly in your Power App?

@Expiscornovus - Thanks for the response.  Unfortunately, I lack the permissions to run Get-AdminFlow.   

The new flow never triggered in my Power App despite showing up within the Power App as a legitimate connection.  

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Top Solution Authors
Users online (2,861)