cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
JeremyWhite
Frequent Visitor

[Resolved] Power Automate Visual 'Unsuccessful' for other users in Report

Edit - Resolved, first comment!
Hi, I'm using the 'Power Automate for Power BI' visual and it's working great for me (from desktop and from published report in the web. However in my published report, when other users click the button, it says 'Unsuccessful'. I'm not sure what could be causing this - the users have the correct (owner) permissions for the data source, and the button is still working fine for me, so it isn't a problem with the automation/flow... Any ideas what could be causing this or what else I could try please? Thanks

1 REPLY 1
JeremyWhite
Frequent Visitor

Hi everyone, figured it out. For anyone else trying to allow users to run flows:

  • Go into your Power Automate Flow (Details page, not edit)
  • In the bottom-right corner, there's a section called 'Run-only users'
  • Edit this section and add all of the anticipated report users that'll need this (can add groups as well - currently testing if adding a Teams group by the title of the team works as expected for all users) and this should then work!

Helpful resources

Announcements
MPA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Top Solution Authors
Users online (2,108)