cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Microsoft chadmat
Microsoft

Cannot see Flow in 'call an action' anymore

I created a solution/flow in the same environment as PVA and was able to call into the Flow from PVA at first. Now the Flow no longer shows in the 'call an action' dialog even though they are still in the same environment.

 

Has anyone see this before or know how to solve?

1 ACCEPTED SOLUTION

Accepted Solutions
Microsoft chadmat
Microsoft

Re: Cannot see Flow in 'call an action' anymore

Thanks. It wasn't any of those things. There must be a Flow validation routine before displaying possible Flows to show in the 'call an action'. It didn't like the json payload being returned. I played around with it a bit and it now shows. Thanks. 

View solution in original post

6 REPLIES 6
Microsoft CleberM
Microsoft

Re: Cannot see Flow in 'call an action' anymore

Hi @chadmat ,

 

I never saw that happening before, but here are a couple of things that might have happened:

* The flow got moved out of a solution

* The flow is disabled (turned OFF)

* You somehow lost permission to it

 

I attached the screenshot showing a flow turned OFF. Might want to check those and see if it applies to your flow.

Microsoft chadmat
Microsoft

Re: Cannot see Flow in 'call an action' anymore

Thanks. It wasn't any of those things. There must be a Flow validation routine before displaying possible Flows to show in the 'call an action'. It didn't like the json payload being returned. I played around with it a bit and it now shows. Thanks. 

View solution in original post

muges01
Level: Powered On

Re: Cannot see Flow in 'call an action' anymore

Hi,

I could not see the flows that i have created under 'Call an Action'.

When i click 'Call an Action', it always displaying 'Create new flow' option only.

How did you resolve this issue?

 
Microsoft CleberM
Microsoft

Re: Cannot see Flow in 'call an action' anymore

Hi @muges01 ,

 

Did you move your flow into a Solution? Flows need to be in a solution (any solution) for it to show into the Power Virtual Agent.

 

If that's not the issue, can you give a bit more information? Was it working before, and maybe a screenshot of the issue.

 

Thanks

muges01
Level: Powered On

Re: Cannot see Flow in 'call an action' anymore

Hi CleberM,

 

I didn't move my flow into a solution before. 

 

Now, i can see the flow after I have move the flow into a solution. When i tried to move the flows into a solution, i notice that i couldn't find my second flow to add into the solution. After I remove the SharePoint get action from my second flow, i manage to add the flow into a solution. Is this an expected experience? However, i manage to add the SharePoint get action into the flow back after I have moved the flow into the solution.

 

 

pstrindlundcat
Level: Powered On

Re: Cannot see Flow in 'call an action' anymore

I had the same issue today. Created a new flow from PVA, added a SharePoint action in there and saved it. I could not add the new flow to the Solution. After removing the SharePoint action in the flow I could add the flow to the Solution and it showed up in PVA. So from there I could start building it out without issues.

 

Feels like PVA wants the flow "clean" to be able to add them.

Helpful resources

Announcements
thirdimage

Power Apps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

SecondImage

Difinity Conference

The largest Power BI, Power Platform, and Data conference in New Zealand

Top Solution Authors
Top Kudoed Authors (Last 30 Days)
Users online (4,222)