cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Super User
Super User

Teams App Showing GUID instead of Bot Name

Hi all,

Just building my first bot and that all works fine.  Integration with Teams was a bit...clunky, but I'm wondering if anyone else is seeing the GUID being presented rather than the bot (or even App) name?  I followed the documentation and everything looks like it's filled out correctly, but in the chat for Teams, it represents itself as just the GUID.

 

Thanks for the help.

-Ed-

1 ACCEPTED SOLUTION

Accepted Solutions
Microsoft micchow
Microsoft

Re: Teams App Showing GUID instead of Bot Name

Thank you everyone for raising this issue.  This is a bug and has been fixed on our side.  For bots that have already been deployed to Teams, please follow the steps below to let bot name show up correctly in Teams:

1. Go to PVA, Configuration -> Channel -> Microsoft Teams and delete the channel

2. Re-add Microsoft Teams channel

3. Go to Microsoft Teams App studio and remove the app of the bot

4. Re-install (sideload) the app in Microsoft Teams

 

After step 4, the bot name will show up correctly.  If the user has previously chatted with the bot, they will see the name of the bot in the chat history list staying as a GUID.  That is due to back-end caching, it will be updated after some time when the back-end is updated.

 

Thank you again for your patience.

View solution in original post

7 REPLIES 7
WillPage
Level 8

Re: Teams App Showing GUID instead of Bot Name

I have the same problem.

 

Also, when I add the bot it responds to the greeting and also something else it doesn't understand. I can't see what the bot has been sent.

Steensgaard
Level: Powered On

Re: Teams App Showing GUID instead of Bot Name

I have the same experience

Highlighted
WillPage
Level 8

Re: Teams App Showing GUID instead of Bot Name

It must be a bug. Also the Teams bot does not seem to respond to any published changes in Power Virtual Agents.

barne77
Level: Powered On

Re: Teams App Showing GUID instead of Bot Name

I have the same issues???

Ashish2012
Level 8

Re: Teams App Showing GUID instead of Bot Name

Its a Bug in Power Virtual for Teams. 

Steensgaard
Level: Powered On

Re: Teams App Showing GUID instead of Bot Name

is this being prioritized ?

Microsoft micchow
Microsoft

Re: Teams App Showing GUID instead of Bot Name

Thank you everyone for raising this issue.  This is a bug and has been fixed on our side.  For bots that have already been deployed to Teams, please follow the steps below to let bot name show up correctly in Teams:

1. Go to PVA, Configuration -> Channel -> Microsoft Teams and delete the channel

2. Re-add Microsoft Teams channel

3. Go to Microsoft Teams App studio and remove the app of the bot

4. Re-install (sideload) the app in Microsoft Teams

 

After step 4, the bot name will show up correctly.  If the user has previously chatted with the bot, they will see the name of the bot in the chat history list staying as a GUID.  That is due to back-end caching, it will be updated after some time when the back-end is updated.

 

Thank you again for your patience.

View solution in original post

Helpful resources

Announcements
thirdimage

Power Apps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

SecondImage

Difinity Conference

The largest Power BI, Power Platform, and Data conference in New Zealand

Top Solution Authors
Top Kudoed Authors (Last 30 Days)
Users online (5,223)