Kitty Video App - Demo of Video Control Usage with YouTube

by PowerApps Staff audrieg ‎02-12-2017 03:06 PM - edited ‎02-12-2017 03:07 PM

I made this little PowerApp today just to demo the way you can use the Video Control with YouTube Videos. Let me know if you'd like to dive deeper into this one. 

 

Prep: I created an Excel spreadsheet with three columns. My goal was to test the functionality with each column. 

KittyFunSplash.PNG

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Here are the columns I used:

 

1. Title (I didn't really want to match the titles to what YouTube had though, but you could of course.)

2. Embed HTML (The Embed iFrame code that YouTube gives you to embed video on a page - which didn't work well with video control, so I didn't use it.)

3. Link (The link that YouTube gives you when you click on "Share". This worked best in the format of this app.)

 

I was also careful to format the table range in Excel as a "Table", so it would show up properly in PowerApps. (See more on that here).

 

I imported the Excel data and then created two objects on my screen:

A Video Control that I named VideoPlayer (Insert>Media>Video)

A Gallery Control that I named MovieGallery (Insert>Gallery>Text Vertical)

 

I formatted my gallery to have the three columns in my newly embedded data from excel.

 

For the VideoPlayer Control I set the media property to:

MovieGallery.Selected.Link

 

For the Video Control I set the Items property to:

Table1

 

Finally, I made a little play button (image I imported) and added that to the gallery just so you could click on it to play a movie.

 

And that's it! It worked!

 

Let me know if you have questions. I was unable to save the PowerApp as an attachment here, but if you private message me with your email, I'll send it out to you!

 

Enjoy your PowerApp experience!

 

Audrie

Comments
by hpkeong
on ‎02-24-2017 07:36 AM

Hi

Knowing how to "code" is not imporant, but knowing how to create attractive UI and Attractive Apps is more important. Thanks for sharing to improve my future works (Not only coding!) but to look into UI improvement and better presentation.

Thanks, Audrie,

by PowerApps Staff Audrie-MS
on ‎02-25-2017 07:26 AM

@hpkeong Your comment made my day! It's my pleasure to help to enhance your PowerApp experience and consumer adoption! -Audrie

by UB400
on ‎03-08-2017 12:02 PM

@Audrie-MS I'm running into issues, where Youtube videos work fine in PowerApps on a Pc, but not on IoS devices. I suspect it has something to do with  "importing" the data into PowerApps.

 

I had a look around, but I'm not really clear on how to go about "importing" data into PowerApps. From all the examples I have found, they all talk about "exporting" data first to an Excel file and then importing it back, you did not mention this in your post.

 

Also why is it that data needs to be "imported", why doesn't reading the URL from the entity work?

 

In my scenario, I have gallerys that are reading data from entities in CDS and every time the gallery item is selected, I need to play the video from the link in the Gallery.

 

Any help on this would be greatly appreciated.

by PowerApps Staff Audrie-MS
on ‎03-13-2017 06:56 AM

@UB400 Thank you for your comment. I did not do any imports to make this happen, I just used the URL of the YouTube video. I will try and repro on my iOS devices (I am using an iPhone and iPad to test) and will let you know if this is a bug. If it is I will get it logged for a future release.

 

Thanks for letting us know,

Audrie

 

by UB400
on ‎03-13-2017 07:00 AM

@Audrie-MS Thanks, greatly appreciated. I'm quite befuddled with this one, as it works if the URL is added directly to the video control, but does not work for me when I call it from a Gallery or Collection.

by PowerApps Staff Audrie-MS
on ‎03-13-2017 07:03 AM

@UB400 That is a gallery on the left of the above screen shot that I was using, so agree that it's odd. I'll do some testing.

About the Author
Labels