cancel
Showing results for 
Search instead for 
Did you mean: 

PowerApps Training App - new way to learn

In first chapter of this series, you will learn all you need to know to start using controls. Each exercise includes an introduction, a task for you to complete, and - in the gray sandbox area to the right - some pre-built controls that you have to improve. As soon as you finish your tasks, the "Next" button will automatically appear to take you to the subsequent challenge.

 

2018-03-06 06_54_13-PATApp Chapter 1 ‎- PowerApps.png

 

To start learning, open the attached file in PowerApps (Windows app is recommended for best experience). You can use comments area in this blog post to show your picture from exercise 10!

Comments

Very nicely done Michal!

I will be sending this blog to everyone that wants to learn PowerApps.

Hi Michal,

 

Can you please specify the application/software required to open .msapp extension file which you have uploaded above.

 

Thanks,

Kamna

Hi @Kamna,

 

Go to PowerApps.com and sign in with your Office 365 account.

 

Go to 'Create App:

PowerApps.png

 

Then click on Open and select browse to select the downloaded msapp file.

Browse.png

 

 

Let me know if you don't come right.

Thanks @Dawidvh. Its working now.

Awesome Michal!

 

Would you also add your app to the app gallery too? I'll be amplifying this awesome initiative too!

 

Thanks again,

Audrie

I and a colleague have been working through this and are both stuck on Screen7. We're able to get the image from the camera stored in a variable, using "Set(_MyPhoto, Camera1.Photo)". However, when we set the other image control's "Image" property to "_MyPhoto", nothing comes up. I added another label to the screen to show the text version of that variable, and it shows "appres://blobmanager/0a9b9c7fd9164a9e89ae89aae2072340/xx", where xx is the number of the image. Since this number increments each time the camera control is selected, I know the camera control and variable are working correctly. 

 

Is the formula for the Image property something other than just the variable name?

@ChadVKealeythe only reason I can think of right now is that your code "Set(_MyPhoto, Camera1.Photo)" is in some other control than the camera itself, like a standalone button you've added. It is a limitation of the Camera control that images can be captured only when the camera itself is clicked, during the OnSelect event.

 

The Image property for the image container should be just the variable name (_MyPhoto).

@MichalRok, here's a short video showing how I have the controls in the App set up and how it's (not) working. The one other thing I forgot to mention is that I'm doing this in the desktop version of PowerApps Studio, rather than the web-based version, but I don't see how that would make a difference.

 

Clearly, the camera is seeing the appropriate feed, and the image is being stored in a variable, but I can't make that variable appear in the image control. I think I'm going to try creating a new PA with the camera control from scratch to see if that helps.

 

-Chad

It seems you're doing it 100%, and I have no idea why it's not working. Can you try with web-based PowerApps just to compare? The Windows Studio client is being retired anyway...

@MichalRok, it does work in the web-based PowerApps, at least using Chrome or Firefox (in IE, I don't get prompted to allow permissions for the webcam).

Meet Our Blog Authors