Reply
Highlighted
Microsoft Employee
Posts: 181
Registered: ‎09-19-2016
Accepted Solution

office365users.myprofile() suddenly started returning 403 errors

I've been using Office365Users.UserProfile(User().Email) to populate a profile form and it's been working successfully for the last two weeks. But today (when I shared it out for UAT, of course) it has started to return 403 errors every time.

I tried MyProfile instead, and got the exact same error.

 

The service returned an error: Office365Users!UserProfile: {"status":403,"message":"Insufficient privileges to complete the operation.","source":"127.0.0.1"}

The service returned an error: Office365Users!MyProfile: {"status":403,"message":"Insufficient privileges to complete the operation.","source":"127.0.0.1"}

 

I'm encountering this issue both in browser, web editor preview mode and on the phone app (iOS)


Accepted Solutions
PowerApps Staff
Posts: 55
Registered: ‎04-26-2016

Re: office365users.myprofile() suddenly started returning 403 errors

This issue is now resolved fully and you should no longer see these errors. Please let us know if you still experience any errors.

View solution in original post


All Replies
Level: Power Up
Posts: 2
Registered: ‎04-15-2017

Re: office365users.myprofile() suddenly started returning 403 errors

I am also getting the same issue from today. I think some recent update on Office 365 might have caused the issue. I hope Microsoft will resolve this soon with top priority.

Level: Powered On
Posts: 47
Registered: ‎09-27-2016

Re: office365users.myprofile() suddenly started returning 403 errors

Same issue here, odd to say but glad others having the issue, saves me time on troublshooting.

PowerApps Staff
Posts: 74
Registered: ‎04-26-2016

Re: office365users.myprofile() suddenly started returning 403 errors

We are actively investigating, apologies for the trouble. Thanks for letting us know

Level: Powered On
Posts: 2
Registered: ‎04-15-2017

Re: office365users.myprofile() suddenly started returning 403 errors

Same error on my side since about one day. Hoping for a fix/woraround! Thx, Toni

Level: Power Up
Posts: 2
Registered: ‎04-15-2017

Re: office365users.myprofile() suddenly started returning 403 errors

same status": 403, "message": "Insufficient privileges to complete the operation.", "source": "127.0.0.1" issue here

PowerApps Staff
Posts: 55
Registered: ‎04-26-2016

Re: office365users.myprofile() suddenly started returning 403 errors

We have the right folks investigating this issue. We'll provide an update on the support page when the issue is resolved: https://powerapps.microsoft.com/en-us/support/ Apologies for the inconvenience due to this incident.

PowerApps Staff
Posts: 55
Registered: ‎04-26-2016

Re: office365users.myprofile() suddenly started returning 403 errors

Engineers have resolved the issue, but existing connections will continue to experience errors for up to another hour. New Office 365 Users connections will work correctly. Last updated at: 4/15/2017 2:00 PM PST

Latest status here: https://powerapps.microsoft.com/en-us/support/

PowerApps Staff
Posts: 55
Registered: ‎04-26-2016

Re: office365users.myprofile() suddenly started returning 403 errors

This issue is now resolved fully and you should no longer see these errors. Please let us know if you still experience any errors.
Level: Power Up
Posts: 2
Registered: ‎04-15-2017

Re: office365users.myprofile() suddenly started returning 403 errors

Resolved. Thank you Smiley Wink