cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
porski
Frequent Visitor

Business rule not firing for another user

Hello,

 

I have created a business rule and it does not fire for my test user, unless i give that user a "system customizer" role. I have created a custom role for this user, primarily write/edit to the custom entity. Are there any specific roles/permissions i need to assign for my test user without giving him the "system customizer" role?

 

Below is a screenshot of the custom security role for my test user

 

Custom security role-2.png

 

The business rule works well for my account,  i have the system administrator and customizer role

 

Thanks in advance!

1 ACCEPTED SOLUTION

Accepted Solutions
CFernandes
Super User III
Super User III

Hey @porski 

 

Can you please review - 

 

https://docs.microsoft.com/en-us/powerapps/maker/model-driven-apps/create-business-rules-recommendat... 

 

Also have a look at  - https://powerusers.microsoft.com/t5/Building-Power-Apps/Model-Driven-Business-Rules-not-Running-for-...

 

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

 

View solution in original post

3 REPLIES 3
CFernandes
Super User III
Super User III

Hey @porski 

 

Can you please review - 

 

https://docs.microsoft.com/en-us/powerapps/maker/model-driven-apps/create-business-rules-recommendat... 

 

Also have a look at  - https://powerusers.microsoft.com/t5/Building-Power-Apps/Model-Driven-Business-Rules-not-Running-for-...

 

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

 

View solution in original post

porski
Frequent Visitor

The second link that you have mentioned helped me resolve the problem. Thanks for the help!

 

In summary, this is what i did:

1. Downloaded the solution (minimum privileges security role template) from the Download Center
2. Imported the solution
3. Created a copy of the security role, applied permissions for my custom entity, and then assigned to my test user

 

More information on the security role template here: https://docs.microsoft.com/en-us/power-platform/admin/database-security

 

Hey @porski ,

 

I really appreciate, that you have shared the detailed steps that helped you resolve the problem. 

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Top Solution Authors
Users online (31,541)