cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ggosal
New Member

Adding a skill gives me "This skill couldn't be validated. Review details and try again"

I'm using the skill bot at https://github.com/microsoft/BotBuilder-Samples/tree/main/samples/python/80.skills-simple-bot-to-bot.... The only changes I've made are to the App ID and secret. I've deployed the bot to Azure using the CLI as directed here: https://docs.microsoft.com/en-us/azure/bot-service/bot-builder-deploy-az-cli?view=azure-bot-service-....

 

The bot works as expected when using "Test in WebChat" in Azure, but when I open the manifest URL in the browser I'm getting a 404 error. I'm using the URL https://[app-name].azurewebsites.net/manifest/manifest-1.0.json, which I think is what it should be as the manifest.json file is in the folder at wwwroot/manifest/. When I visit https://gg-echo-skill-bot-app.azurewebsites.net/api/messages I get a 405 error as expected.

 

I'm using a different Azure tenant to the PowerVA tenant, but I think it should work as when setting up the app I used the --available-to-other-tenants flag.

1 REPLY 1
ali7
New Member

🤑

Helpful resources

Announcements
March Update

Welcome to the User Group Private Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

Top Solution Authors
Top Kudoed Authors
Users online (60,143)