cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
JBlackham
New Member

Error Publishing Updates to PVA

I published the PVA to a demo site and later made some additional tweaks to a topic.  Now when I try to publish these changes I get an error message that 1 topic contains errors.  I've run the topic checker on the topic I changed and it says there are no errors and warnings, but publishing still fails.  Is there something I'm missing or is this a potential bug?

 

Thanks!

5 REPLIES 5
Vincent_vds
New Member

I encounter the same issue. Can you check if you have the same behavior in your flow?

Just to give some background info:

  1. Bot is used to create a workspace in O365 based on a template (Teams, SharePoint...)
  2. User must fill in some parameters and via the Power Automate action the input is validated (check if the team/site already exists...)
  3. Based on the outcome of Power Automate, a condition decides if the bot goes to the next step or sends the user to the original question (see screenshot). 

I've figured out that this issue happens if I create a link between the outcome of the condition and the original question. If I delete this link, I can publish the bot. 

 

This seems like a bug to me? 

ggupta
PVA
PVA

@JBlackham, can you share some more information on what you are doing in your topic? If possible, please share a screenshot of the dialog where the error shows? Thanks, Gitika.

@Vincent_vds --  That was my problem!  Thanks for helping me debug it.  My flow had a recursive loop and went back to an earlier stage in the flow.  Apparently it can't/won't publish if you do that.  If you aren't allowed to make a recursive flow loop, the drag-and-drop editor should flag that as an error or at least flag it as a warning.  It instead said that there was nothing wrong and allowed you to publish and then failed with unhelpful error logs.

@ggupta any idea if this is a bug or it has been implemented by design? 

@Vincent_vds, this does seem like a bug: Recursive dialogs aren't allowed, but we don't error out in the dialog. In fact, from what I see, this doesn't have anything to do with the Power Automate flow you have, its the fact that you have a recursive dialog that's causing the publish to fail.

I have flagged it to the team and will write back when I know more about how we will handle it. Thanks.

Helpful resources

Announcements
Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Center-of-Excellence-Starter-Kit-cropped 768x460.png

The Total Economic Impact™ of Power Virtual Agents

Read this 2021 commissioned study, conducted by Forrester Consulting.

Top Solution Authors
Top Kudoed Authors
Users online (3,446)