cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Super User II
Super User II

Teams App Showing GUID instead of Bot Name

Hi all,

Just building my first bot and that all works fine.  Integration with Teams was a bit...clunky, but I'm wondering if anyone else is seeing the GUID being presented rather than the bot (or even App) name?  I followed the documentation and everything looks like it's filled out correctly, but in the chat for Teams, it represents itself as just the GUID.

 

Thanks for the help.

-Ed-

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Teams App Showing GUID instead of Bot Name

Thank you everyone for raising this issue.  This is a bug and has been fixed on our side.  For bots that have already been deployed to Teams, please follow the steps below to let bot name show up correctly in Teams:

1. Go to PVA, Configuration -> Channel -> Microsoft Teams and delete the channel

2. Re-add Microsoft Teams channel

3. Go to Microsoft Teams App studio and remove the app of the bot

4. Re-install (sideload) the app in Microsoft Teams

 

After step 4, the bot name will show up correctly.  If the user has previously chatted with the bot, they will see the name of the bot in the chat history list staying as a GUID.  That is due to back-end caching, it will be updated after some time when the back-end is updated.

 

Thank you again for your patience.

View solution in original post

7 REPLIES 7
Highlighted
Impactful Individual
Impactful Individual

Re: Teams App Showing GUID instead of Bot Name

I have the same problem.

 

Also, when I add the bot it responds to the greeting and also something else it doesn't understand. I can't see what the bot has been sent.

Highlighted
Regular Visitor

Re: Teams App Showing GUID instead of Bot Name

I have the same experience

Highlighted
Impactful Individual
Impactful Individual

Re: Teams App Showing GUID instead of Bot Name

It must be a bug. Also the Teams bot does not seem to respond to any published changes in Power Virtual Agents.

Highlighted
Regular Visitor

Re: Teams App Showing GUID instead of Bot Name

I have the same issues???

Highlighted

Re: Teams App Showing GUID instead of Bot Name

Its a Bug in Power Virtual for Teams. 

Highlighted
Regular Visitor

Re: Teams App Showing GUID instead of Bot Name

is this being prioritized ?

Highlighted

Re: Teams App Showing GUID instead of Bot Name

Thank you everyone for raising this issue.  This is a bug and has been fixed on our side.  For bots that have already been deployed to Teams, please follow the steps below to let bot name show up correctly in Teams:

1. Go to PVA, Configuration -> Channel -> Microsoft Teams and delete the channel

2. Re-add Microsoft Teams channel

3. Go to Microsoft Teams App studio and remove the app of the bot

4. Re-install (sideload) the app in Microsoft Teams

 

After step 4, the bot name will show up correctly.  If the user has previously chatted with the bot, they will see the name of the bot in the chat history list staying as a GUID.  That is due to back-end caching, it will be updated after some time when the back-end is updated.

 

Thank you again for your patience.

View solution in original post

Helpful resources

Announcements
Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Community Conference

Experience what’s next for Power Virtual Agents

See the latest Power Virtual Agents innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Community Conference

Power Platform Community Conference

Find your favorite faces from the community presenting at the Power Platform Community Conference!

FirstImage

Microsoft Ignite 2020

Check out the announcement of Power Platform content at Microsoft Ignite!

Top Solution Authors
Top Kudoed Authors
Users online (5,301)