cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
P-E-P
Frequent Visitor

Power Pages Google OAuth2.0 not working

Hi,

 

When completing registration of a new user via Google OAuth2.0 I get redirected in to this "redeem invitation page" in the portal, even though I have set the redirect URI to <mydomain>/signin-google. The user is still not logged in even though I don't get an error messsage.

 

What am I missing?

PEP_0-1659511496682.png

 

1 ACCEPTED SOLUTION

Accepted Solutions
P-E-P
Frequent Visitor

Thanks for your answer. The problem was that Open Registration was not toggled to on.

View solution in original post

2 REPLIES 2
hugobernier
Administrator
Administrator

Thanks for posting your question here, @P-E-P . Can you confirm whether you have invitations enabled (Authentication/Registration/InvitationEnabled under Site Settings in the Portal Management app) and confirm that the user who is trying to log in does not already exist as a contact?

 

Reference:

https://docs.microsoft.com/power-apps/maker/portals/configure/configure-oauth2-google

P-E-P
Frequent Visitor

Thanks for your answer. The problem was that Open Registration was not toggled to on.

Helpful resources

Announcements
Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Top Kudoed Authors
Users online (5,960)