cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
mscherotter
Microsoft
Microsoft

Topic validates fine and saves but the topic list sill shows "2 errors" preventing publishing

A topic validates fine in the topic checker on the canvas but when the bot is published, 2 errors are shown in the topic status with no description.

Going to the authoring canvas shows no errors.

Any suggestions?

Thanks,
Michael

6 REPLIES 6
renatoromao
Super User
Super User

Hi @mscherotter ,

 

When you are publishing the bot, the error occurred showing your custom topic or just an error in topics?

Because the problem could be inside another topic.


Did I answer your question? Mark my post as a solution!
Thanks!

Renato Romão,

Connect with me here 😉

Power Virtual Agents course (+2.650 students) : English | Português

Hi @mscherotter,

Thanks for reporting the issue. We'd like to debug this with your help. Can you share a screenshot of your Topic list and Publish where it shows the errors, and then the authoring canvas for the topic, that would be a good starting point. 

Thanks
Gitika

Any solution to this issue ? I'm experiencing the same thing.

2 errors show next to the topic in Topic view, but when I go into Authoring Canvas and check the topic no errors show.

There are no errors in any of the other topics.

 

Publishing fails with this unhelpful message:

 

The bot content is not valid. Please fix the following errors [{"Key":"new_topic_3716d81410e6489c8cb32ea2d5be14a5_db1f76b081dc43389df9dd2df7518737_confirmedsuccess","Value":[{"NodeId":"873b869b-eaff-4dc2-91d2-674ae00cd08d","ValidationRule":11,"ViolationSeverity":0}]},{"Key":"new_topic_c01001a7541140d1920c3e1d71eb169f","Value":[{"NodeId":"5996932a-7931-41df-916d-5aac4f770f92","ValidationRule":10,"ViolationSeverity":1},{"NodeId":"5996932a-7931-41df-916d-5aac4f770f92","ValidationRule":10,"ViolationSeverity":1}]}]
Diagnostic Trace Id: LqNmy

some progress with this - though not what I expected.

 

The topic showing "2 Errors" but with no errors reported by topic check, was actually not the only topic causing problems with publishing. By gradually working through the topic removing actions where I could, I managed to remove the reported 2 errors, though it was actually not obvious why - the removed action had no inherent errors.

 

The error caused during publishing was caused by a different topic - named "confirmedsuccess" and mentioned in the error message below. It had a loose system included node for asking for feedback - once this was connected to another node, the publish worked.

 

I am facing the same error. how do I resolve it?

Lvdk
Frequent Visitor

Hi @mscherotter ,

 

I'm having the same issue with my PVA. Did you manage to fix your issue?  

Helpful resources

Announcements
Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Center-of-Excellence-Starter-Kit-cropped 768x460.png

The Total Economic Impact™ of Power Virtual Agents

Read this 2021 commissioned study, conducted by Forrester Consulting.

Top Solution Authors
Top Kudoed Authors
Users online (2,065)