cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Microsoft
Microsoft

Topic validates fine and saves but the topic list sill shows "2 errors" preventing publishing

A topic validates fine in the topic checker on the canvas but when the bot is published, 2 errors are shown in the topic status with no description.

Going to the authoring canvas shows no errors.

Any suggestions?

Thanks,
Michael

4 REPLIES 4
Highlighted
Super User
Super User

Re: Topic validates fine and saves but the topic list sill shows "2 errors" preventing publishing

Hi @mscherotter ,

 

When you are publishing the bot, the error occurred showing your custom topic or just an error in topics?

Because the problem could be inside another topic.


Did I answer your question? Mark my post as a solution!
Thanks!

Renato Romão,

Please, vote in my app (YouTube App using Power Apps): https://powerusers.microsoft.com/t5/Demo-Extravaganza-2020/YouTube-app-using-Power-Apps/cns-p/596244
Highlighted
PVA
PVA

Re: Topic validates fine and saves but the topic list sill shows "2 errors" preventing publishing

Hi @mscherotter,

Thanks for reporting the issue. We'd like to debug this with your help. Can you share a screenshot of your Topic list and Publish where it shows the errors, and then the authoring canvas for the topic, that would be a good starting point. 

Thanks
Gitika

Highlighted
Advocate I
Advocate I

Re: Topic validates fine and saves but the topic list sill shows "2 errors" preventing publishing

Any solution to this issue ? I'm experiencing the same thing.

2 errors show next to the topic in Topic view, but when I go into Authoring Canvas and check the topic no errors show.

There are no errors in any of the other topics.

 

Publishing fails with this unhelpful message:

 

The bot content is not valid. Please fix the following errors [{"Key":"new_topic_3716d81410e6489c8cb32ea2d5be14a5_db1f76b081dc43389df9dd2df7518737_confirmedsuccess","Value":[{"NodeId":"873b869b-eaff-4dc2-91d2-674ae00cd08d","ValidationRule":11,"ViolationSeverity":0}]},{"Key":"new_topic_c01001a7541140d1920c3e1d71eb169f","Value":[{"NodeId":"5996932a-7931-41df-916d-5aac4f770f92","ValidationRule":10,"ViolationSeverity":1},{"NodeId":"5996932a-7931-41df-916d-5aac4f770f92","ValidationRule":10,"ViolationSeverity":1}]}]
Diagnostic Trace Id: LqNmy

Highlighted
Advocate I
Advocate I

Re: Topic validates fine and saves but the topic list sill shows "2 errors" preventing publishing

some progress with this - though not what I expected.

 

The topic showing "2 Errors" but with no errors reported by topic check, was actually not the only topic causing problems with publishing. By gradually working through the topic removing actions where I could, I managed to remove the reported 2 errors, though it was actually not obvious why - the removed action had no inherent errors.

 

The error caused during publishing was caused by a different topic - named "confirmedsuccess" and mentioned in the error message below. It had a loose system included node for asking for feedback - once this was connected to another node, the publish worked.

 

Helpful resources

Announcements
PVA Thumb

Video of the Week

Show/Hide Bots (PVA) In Users Preferred Language on Power Apps Portals

Power Platform 2020 release wave 2 plan

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

PVA Multi Language

Power Virtual Agents Gaining Traction

Power Virtual Agents is now available in more languages.

PVA Bot Variables

Power Virtual Agents Bot Variables

Reusing variables across topics, and setting variable values from external sources.

BOT Sharing Gallery

BOT Sharing Gallery is now LIVE!

Want to Share a ChatBot? Post it in our Bot Sharing Gallery!

Top Solution Authors
Users online (8,322)