cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
summercoke77
Regular Visitor

Bad Gateway when trying to access sharepoint list using REST API

i am using Power automate to getting data from sharepoint list without using REST API directly.

 

recently i have a requirement to use REST API to perform aggregate function sum and average the SharePoint list column.

 

Following is the sample flow i did

summercoke77_1-1613727649578.png

 

i used the send an HTTP request to sharepoint in automate instead, see below.

 

summercoke77_0-1613727581646.png

 

but when run process gets stuck in send an http request to SharePoint step.

and following is the error message

summercoke77_2-1613727751463.png

 

i tried to create a new list with simply two column list also same error.

 

I create a simple list in another site also i ran into same error.

 

what do i missed here ?

 

any pointer is  very very much appreciated and many thanks in advance. ...

 

 

Note : the flow will keep running for long time and will required to cancel the running. it just wont timed out or throw a run time error other than the bad gateway message i shown above.

1 ACCEPTED SOLUTION

Accepted Solutions
Gopala_Krishna
Solution Sage
Solution Sage

@summercoke77 

This usually happens when there is an error in the query syntax that we are trying to pass, or we have misconfigured the data when passing the query.

 

I suggest to please check the data present in the action body of the "Send HTTP request to SharePoint" action and check if you have misconfigured or entered an incorrect input.

 

----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

if the information shared helps you, please consider giving a thumbs up 👍 and mark solution as resolved

View solution in original post

3 REPLIES 3
Gopala_Krishna
Solution Sage
Solution Sage

@summercoke77 

This usually happens when there is an error in the query syntax that we are trying to pass, or we have misconfigured the data when passing the query.

 

I suggest to please check the data present in the action body of the "Send HTTP request to SharePoint" action and check if you have misconfigured or entered an incorrect input.

 

----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

if the information shared helps you, please consider giving a thumbs up 👍 and mark solution as resolved

brooksg23
Regular Visitor

@summercoke77 did you figure out what syntax you had incorrect that was invoking the bad gateway error message? I am facing a similar problem. Thanks in advance!

In my scenario the BadGateway error message was caused because of a column validation on that list. The value in that column did not meet the column validation, hence the Bad Gateway 502 error. 

 

bassiekb1983_0-1657568067424.png

 

Helpful resources

Announcements
Power Automate News & Announcements

Power Automate News & Announcements

Keep up to date with current events and community announcements in the Power Automate community.

Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Power Automate Community Blog

Power Automate Community Blog

Check out the latest Community Blog from the community!

Users online (2,786)