cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
NachoBenz
Regular Visitor

Cosmos query documents failed - NotFound - 2

I have a super simple flow, that "did" work, and now it does not.

 

It a button trigger, and then a query documents for cosmos DB.

 

When I ran it last night, it seemed to work fine, but today, I get an error.  "Not found"

 

I even tried to create a brand new flow, and get the same error.

 

The same query works fine in Azure data explorer.

 

SELECT * FROM problemCode c WHERE c.id = "G213" AND c.programID = "CCNA-ABTA"

 

Error output from body
{
  "code""NotFound",
  "message""Message: {\"Errors\":[\"Owner resource does not exist\"]}\r\nActivityId: 5c77ad11-e480-44e7-a646-04f8f115b661, Request URI: /apps/6c5e39d2-6966-4c0b-850c-3bc5fb78504b/services/ac48552d-9713-44c2-bdb2-7804dd131ab6/partitions/13e0f270-af2f-400b-8fff-d6f051657eec/replicas/131850800126651599s, RequestStats: \r\nRequestStartTime: 2018-11-01T00:59:49.8634194Z, Number of regions attempted: 1\r\nResponseTime: 2018-11-01T00:59:49.8838042Z, StoreReadResult: StorePhysicalAddress: rntbd://10.100.137.175:11000/apps/6c5e39d2-6966-4c0b-850c-3bc5fb78504b/services/ac48552d-9713-44c2-bdb2-7804dd131ab6/partitions/13e0f270-af2f-400b-8fff-d6f051657eec/replicas/131850800126651599s, LSN: 101, GlobalCommittedLsn: 101, PartitionKeyRangeId: , IsValid: True, StatusCode: 404, IsGone: False, IsNotFound: True, IsInvalidPartition: False, RequestCharge: 1, ItemLSN: -1, SessionToken: -1#101, ResourceType: Collection, OperationType: Read\r\nResponseTime: 2018-11-01T00:59:49.8838042Z, StoreReadResult: StorePhysicalAddress: rntbd://10.100.136.46:11000/apps/6c5e39d2-6966-4c0b-850c-3bc5fb78504b/services/ac48552d-9713-44c2-bdb2-7804dd131ab6/partitions/13e0f270-af2f-400b-8fff-d6f051657eec/replicas/131754353611871306s, LSN: 101, GlobalCommittedLsn: 101, PartitionKeyRangeId: , IsValid: True, StatusCode: 404, IsGone: False, IsNotFound: True, IsInvalidPartition: False, RequestCharge: 1, ItemLSN: -1, SessionToken: -1#101, ResourceType: Collection, OperationType: Read\r\n, SDK: Microsoft.Azure.Documents.Common/2.1.0.0"
}

 

Flow-error.PNG

4 REPLIES 4
Anonymous
Not applicable

Disregard original error.  I was in 2 different tenants, and I think the one had extra security.

Trouble now is I get un-authorized on the cosmos delete document action.  Query works fine, results are as expected.

 

Passing the _rid to the delete action

 

The account I creatd and ran the flow with has contributor access to the Azure RG with the cosmos DB in it.

NachoBenz
Regular Visitor

Disregard original error.  I was in 2 different tenants, and I think the one had extra security.

Trouble now is I get un-authorized on the cosmos delete document action.  Query works fine, results are as expected.

 

Passing the _rid to the delete action

 

The account I creatd and ran the flow with has contributor access to the Azure RG with the cosmos DB in it.

Hi @NachoBenz,

 

What’s your current situation?

Are you still having the issue?

The error says that owner resource doesn’t exist. Please make sure you do have access and resource to be queried.

If you are still having the issue, please feel free post back.

Please check the following doc for a reference:

https://docs.microsoft.com/en-us/rest/api/cosmos-db-resource-provider/databaseaccounts/listbyresourc...

 

Best regards,

Mabel

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

you can disregard this one, I opened a new thread for the unauthorized errror


@v-yamao-msft wrote:

Hi @NachoBenz,

 

What’s your current situation?

Are you still having the issue?

The error says that owner resource doesn’t exist. Please make sure you do have access and resource to be queried.

If you are still having the issue, please feel free post back.

Please check the following doc for a reference:

https://docs.microsoft.com/en-us/rest/api/cosmos-db-resource-provider/databaseaccounts/listbyresourc...

 

Best regards,

Mabel



.  The issue here was that I was in the wrong Flow tenant as compared to Azure.  (too different orgs). 

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

New Ideas Forum MPA.jpg

A new place to submit your Ideas for Power Automate

Announcing a new way to share your feedback with the Power Automate Team.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

MPA Licensing.jpg

Ask your licensing questions at the Power Automate AMA!

Join Priya Kodukula and the licensing team, super users and MVPs to find answers to your questions on Power Automate licensing.

Users online (5,145)