cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
HughBP
Frequent Visitor

Help with Xero HTTP GET

Hello everyone,

I am struggling with API GET request authentication. I have successfully set up an authorisation flow, and now I am going crazy trying to run a simple GET request.. 

 

My access token has the following scope: 

openid profile email accounting.transactions accounting.contacts accounting.settings payroll.payruns payroll.payslip payroll.timesheets payroll.settings payroll.employees payroll.employees.read offline_access
 
When setting up the request headers, I model it after the Xero API Explorer: https://api-explorer.xero.com/payrollau/employees/getemployees

 

HughBP_4-1652232373222.png

 

 

Despite all that, the result is always the same:

HughBP_3-1652229414381.png

 

I am also using Postman and everything there is working exactly as it should. 

 

Any help would be appreciated. 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
HughBP
Frequent Visitor

Solved. The issue was the apostrophe and + sign

View solution in original post

1 REPLY 1
HughBP
Frequent Visitor

Solved. The issue was the apostrophe and + sign

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Power Automate Designer Feedback_carousel.jpg

Help make Flow Design easier

Are you new to designing flows? What is your biggest struggle with Power Automate Designer? Help us make it more user friendly!

Top Solution Authors
Users online (2,248)