cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
icee8123
Frequent Visitor

Http Action - Connect to Web API with Active Directory OAuth

Hello everyone,

 

I'm trying to call a custom web api hosted in azure that is also implementing an Azure AD OAuth authentication, so in the Http Action in the flow I configured the Authentication part of the action using Active Directory OAuth, but for some reason, I keep getting this error saying that the application name cannot be found in the tenant.

screen1.png

 

I'm a bit confused now with the tenant setup in the flow, is it the tenant guid id or just like the domain name? and in the audience field is it  the application name? I check my app registration in azure and I'm sure im using the tenant ids etc..

screen2.png

 

Has anyone tried this setup before? 🙂 

 

Any help is appreciated.


Thank you in advance.

 

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
icee8123
Frequent Visitor

If anyone is interested I figured it out after some trial and error in my part. Smiley Happy

 

What worked for me is the Audience and Client ID are the same value.  You can check this in your Azure Portal Application registration, this is the Application ID in the properties.

The Tenant field value is the domain, for example for us its: mytenant.onmicrosoft.com 

 

The HTTP action was able to call the web api and it generated authorization headers. 

 

View solution in original post

3 REPLIES 3
icee8123
Frequent Visitor

If anyone is interested I figured it out after some trial and error in my part. Smiley Happy

 

What worked for me is the Audience and Client ID are the same value.  You can check this in your Azure Portal Application registration, this is the Application ID in the properties.

The Tenant field value is the domain, for example for us its: mytenant.onmicrosoft.com 

 

The HTTP action was able to call the web api and it generated authorization headers. 

 

soilleir
Frequent Visitor

Hi @icee8123    Thanks for the info above. hoping you might be able to help me.  I am new to this type of API authentication method and struggling to get it to work.  When i run my flow to connect to the API via Azure AD the response is always the vendors login screen.  SSO is set up and working when we manually log into the vendors system so thats all good.   But i cant get this to work in Flow and keep getting the vendors login page as a result.

 

Essentially we are trying to download a document via a URL in flow. 

Akuner
Frequent Visitor

Hi @icee8123 

I am having same error as you. I tried updating the audience as client ID. No luck. 

 

Would you know if this authentication works with ADFS token or app has to be registered in Azure? Sorry new to the platform.

Helpful resources

Announcements
October Events

Mark Your Calendars

So many events happening this month - don't miss out!

 WHAT’S NEXT AT MICROSOFT IGNITE 2022

WHAT’S NEXT AT MICROSOFT IGNITE 2022

Explore the latest innovations, learn from product experts and partners, level up your skillset, and create connections from around the world.

Register for a Free Workshop.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Users online (3,793)